0

My router uses Smart Connect which like mesh, allows the router's 2.4 GHz and 5 GHz bands to use the same wireless settings and switches over to the best connection in traffic.

When my headless rpi is on the 2.4 GHz, I can ssh into it just fine. However, when it switches to 5 Ghz, the ssh connection freezes and I have to go into my router and turn off the 5GHz connection and reconnect.

How can I ssh into it when it is on the 5GHz band? In other words, what would I type differently in the command line?

[Edit - new question] I tried assigning a fixed ip address to the device on my router. But this did not work. So it turns out, the switch between 2.4 and 5GHz might not the reason that I cannot ssh into the pi, because I tried turning off 5Ghz signal and it's still not connecting.

However, when I tried typing the ssh like this:

ssh [email protected]

instead of like this:

ssh [email protected]

Then I was able to connect. So the new question is, why is it sometimes freezing / hanging when I type the command as hostname, and is there a setting I can change to fix it.

7
  • I used both. When I swtich from 2.4 to 5G GHz, I change router password. Apr 26, 2023 at 19:16
  • Does your router allow connections between 5GHz devices or does it have "wireless isolation" active on that SSID? Check the router home pages at 192.168.0.1 , 192.168.0.254, 192.168.1.1 or 192.168.1.254 (whichever is applicable to your home network).
    – Dougie
    Apr 26, 2023 at 20:00
  • @toyotaSupra can you elaborate?
    – Jet59black
    Apr 26, 2023 at 20:23
  • @Dougie yes it does allow connections between 5GHz devices.
    – Jet59black
    Apr 26, 2023 at 20:23
  • @et59black. On RPi you have to change password. Disconnected 2.4. then activate password on 5 GHz and vice versa. That what Dougie saying. Apr 27, 2023 at 0:26

3 Answers 3

1

i think during the switch to 5GHz network, your rpi receives a new IP address. I guess thats the reason why connection interrupts. So i would suggest to assign a fixed ip address to your rpi on your router. Hope this helps.

2
  • Yes, that should be a suitable solution. @Jet59black, could you confirm wether this worked for you or not?
    – JJandke
    Apr 28, 2023 at 8:45
  • @JJandke see my edit above.
    – Jet59black
    Apr 30, 2023 at 12:46
0

Are you connecting from a machine also connected to WiFi? Does the Router have "AP Isolation" enabled? If so, you may want to look into disabling AP Isolation between 2.4GHz and 5GHz.

When you set up your Router, it has features to help secure your network. One such method is to separate your WiFi APs such that machines on different APs cannot communicate as if they were on the same LAN. Sometimes this isolation is enabled between the different bands as well as different SSIDs.


Otherwise, does the Raspberry Pi have Internet access when it switches over to 5GHz? Would be good to diagnose and add this detail to your question if my suggestion doesn't work for you.

Additionally, are you connecting via DNS or IP? Can you confirm that when you go from 2.6GHz to 5GHz the IP of the machine stays the same, or that you adjust your connection to the appropiate IP?

2
  • To answer your questions:
    – Jet59black
    Apr 26, 2023 at 17:40
  • 1) Yes, I am on a machine that is also on the wifi. 2) AP Isolation is not enabled. 3) Yes the Pi has internet access when it switches over to 5GHz. 4) I am connecting via Dynamic IP, but it also shows a DNS--sorry not sure what you mean here or how to check that.
    – Jet59black
    Apr 26, 2023 at 17:45
0

ssh doesn't know (or care) WHAT band your WiFi is using or whether you are using Ethernet.

Your problem is elsewhere.

Most likely just a dropped ssh connection.

Have you tried just reconnecting?

If not post output (into you question) of.

ip a && ip r
4
  • Thanks, I added the output as you suggested (above). Also I am running the rpi headless, so only means of talking to it is via the ssh connection, therefore I cannot just reconnect -- I'd have to restart the pi, and that disrupts the programs I am running on it.
    – Jet59black
    Apr 27, 2023 at 2:25
  • You have NOT posted the output. There is absolutely no point in obscuring private IP addresses.
    – Milliways
    Apr 27, 2023 at 9:30
  • You DO NOT have to restart anything to re establish connection.
    – Milliways
    Apr 27, 2023 at 9:34
  • Ok, I didn't know there's no point in obscuring ip addresses -- just being cautious, no need to yell. So, that is the output I got. What are you looking for, do you need to see the private ip's?
    – Jet59black
    Apr 27, 2023 at 13:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.