1

I've just done a fresh install on Raspberry Pi Zero W. I wish to run headerless (I don't have a micro USB keyboard or adapter, nor a mini HDMI cable). I've done this numerous times on the "full fat" Raspberry Pi.

  • installed the OS to the SD card
  • created an empty ssh file on the root
  • created a wpa_supplicant.conf containing the appropriate details including encrypted WiFi password
  • waited the commensurate time for it to do its funky thang on first boot.

It has acquired an IP address from my DHCP server, but when I SSH to it, I'm told Please note that SSH may not work until a valid user has been set up. True to form, the default username and password yield up Access denied. According to a number of online guides, VNC should work out of the box, but that doesn't work either.

How do I get SSH'd in, please?

EDIT I found a mini HMDI cable. The screen is stuck at a "Enter new username" prompt. So, I Googled that. It would seem that (possibly as off about April 2022) there aren't any users created yet. Including the former default.

I still have the problem, though: Am I going to require a micro adapter for a keyboard?

Thanks.

1

3 Answers 3

3

The recent Raspberry Pi OS no longer have a default user or password and require keyboard and screen to set a default user.

There are options in the latest imager to specify settings before imagining (this is far from straightforward but is documented).

See https://raspberrypi.stackexchange.com/a/135703/8697

1
  • I don't have a working SD card. This is a first time install.
    – KDM
    Apr 29, 2023 at 16:22
0

Thanks to a pointer from @Milliways, the answer to my question is "no": I did not need a micro USB adapter.

In fact, the solution is to discard all past knowledge on how to perform this activity manually, and instead rely on the very straightforward Imager tool. Once the required OS is selected, simply click the COG icon, select a username and password, select a WiFi SSID and password, and finally flash the image.

Thanks for the pointer.

0

I am having the same issue so I tried doing it in the imager but when I try to ssh then I get the below error, does anybody know what to do?

@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@ @ WARNING: REMOTE HOST IDENTIFICATION HAS CHANGED! @ @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@ IT IS POSSIBLE THAT SOMEONE IS DOING SOMETHING NASTY! Someone could be eavesdropping on you right now (man-in-the-middle attack)! It is also possible that a host key has just been changed. The fingerprint for the ED25519 key sent by the remote host is SHA256:n0CDVlaKMYqKA1zPMXqlZUcPWkzvSvnf78dcMMtbKwA. Please contact your system administrator. Add correct host key in C:\Users\wcac1/.ssh/known_hosts to get rid of this message. Offending ED25519 key in C:\Users\wcac1/.ssh/known_hosts:4 Host key for raspberrypi has changed and you have requested strict checking. Host key verification failed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.