0

So i wanted to build the driver for my wifi adapter for my raspberry pi 400: https://github.com/morrownr/88x2bu-20210702 And i did everything what was said and then got the error: Your kernel files are not properly installed. So i send in my issue there and I was told the kernel and header version has to be the same. My kernel version is 6.1.21-v8+ and my header version is 6.1.21+. Now how do i fix this (I tried sudo apt install raspberrypi-kernel and raspberrypi-kernel-headers already but didnt help.

9
  • what's the result of ls -l /lib/modules/6.1.21-v8+/build - did you install 64bit pi OS, or are you just running the 64bit kernel with 32bit "userland" May 1, 2023 at 10:22
  • @JaromandaX there is no build foler in there but im using raspberrypi os 32bit lite
    – Jakob
    May 1, 2023 at 10:28
  • oh yeah ... 32bit OS but enabling 64bit kernel ... I remember that being annoying for installing the headers. though, it looks like you don't have headers installed anyway May 1, 2023 at 10:43
  • @JaromandaX can i fix this somehow?
    – Jakob
    May 1, 2023 at 10:48
  • to be honest, I don't think you can compile 64bit drivers in 32bit OS - either don't enable the 64bit kernel, or switch to 64bit OS (that's a re-install, there's no migration to it as far as I know) May 1, 2023 at 11:30

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.