1

When i use the web interface (mmaltest) on motion it doesn't appear to change the operation of motion.

It remembers the values i change on the web interface, so looks like it's working, but is's not transferring the values across when i look using terminal.

1) where does motion look for its motion.conf file? I've seen a conf file in etc/motion.conf and /ect/motion/motion.conf; which one is motion using?

2)if motion runs as user motion, and the permissions are set to 0777 can user pi see /change the motion.conf file?

  • I had the same issue with the web interface. I edited /etc/motion/motion.conf directly and it worked. – iceman Mar 10 '14 at 8:22
  • Thanks iceman, it's reassuring that someone else had problems with motion's web interface; i thought it must be something i was doing wrong! has anyone else manage to change a setting, using the web interface, and see the change in the motion.conf file? – reggie Mar 11 '14 at 6:31
  • Can you elaborate? I don't know if it's the same issue but I can;t get motion to start in daemon no matter what I tried. I ave already edited etc/default/motion & etc/motion/motion.conf to no avail. Seems like a permissions problem. I'm a complete newbie to Rpi so any help would be greatly appreciated. – gtj Jan 19 '16 at 18:53
0

I needed to make the file "motion.conf" user, owner and group to "motion" then it let me control it using the web interface.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.