0

I'm trying to stream video from the pi with live555 (RTSP). I don't have any errors on the raspberry pi side :

pi@raspberrypi:~/live/raspi $ raspivid -w 1024 -h 768 -fps 25 -b 300000 -t 99999999 -o - | ./testRaspi

"h264" stream, from the file "stdin"
Play this stream using the URL "rtsp://10.1.4.1:8554/h264"

(We use port 8000 for optional RTSP-over-HTTP tunneling.)

However, I can't access the stream from another device on the same network :

(base) admin@MBA ~ % mplayer -v rtsp://raspberrypi.local:8554/h264
MPlayer 1.5-14.0.0 (C) 2000-2022 MPlayer Team
get_path('codecs.conf') -> '/Users/admin/.mplayer/codecs.conf'
Reading optional codecs config file /Users/admin/.mplayer/codecs.conf: No such file or directory
Reading optional codecs config file /opt/homebrew/Cellar/mplayer/1.5_1/etc/mplayer/codecs.conf: No such file or directory
Using built-in default codecs.conf.
init_freetype
Using Unoptimized OnScreenDisplay
get_path('fonts') -> '/Users/admin/.mplayer/fonts'
Configuration: --cc=clang --host-cc=clang --disable-cdparanoia --prefix=/opt/homebrew/Cellar/mplayer/1.5_1 --disable-x11 --enable-caca --enable-freetype --disable-libbs2b
CommandLine: '-v' 'rtsp://raspberrypi.local:8554/h264'
Using Darwin accurate timing
get_path('input.conf') -> '/Users/admin/.mplayer/input.conf'
Reading optional input config file /Users/admin/.mplayer/input.conf: No such file or directory
Reading optional input config file /opt/homebrew/Cellar/mplayer/1.5_1/etc/mplayer/input.conf: No such file or directory
Falling back on default (hardcoded) input config
Can't init Apple Remote.
get_path('h264.conf') -> '/Users/admin/.mplayer/h264.conf'

Playing rtsp://raspberrypi.local:8554/h264.
get_path('sub/') -> '/Users/admin/.mplayer/sub/'
STREAM_RTSP, URL: rtsp://raspberrypi.local:8554/h264
Filename for url is now rtsp://raspberrypi.local:8554/h264
Filename for url is now rtsp://raspberrypi.local:8554/h264
Resolving raspberrypi.local for AF_INET6...
Connecting to server raspberrypi.local[fe80:c::e65f:1ff:fe1b:d206]: 8554...

connection timeout
Resolving raspberrypi.local for AF_INET...
Connecting to server raspberrypi.local[10.1.4.1]: 8554...

Failed to connect to server with AF_INET
libavformat version 59.17.102 (internal)
Configuration: --enable-gpl --enable-postproc
[ffmpeg] Opening rtsp://raspberrypi.local:8554/h264
STREAM: [ffmpeg] rtsp://raspberrypi.local:8554/h264
STREAM: Description: FFmpeg
STREAM: Author: 
STREAM: Comment: 
LAVF_check: RTSP input
libavformat file format detected.
[tcp @ 0x104cf7d10]No default whitelist set
[tcp @ 0x104cf7d10]Original list of addresses:
[tcp @ 0x104cf7d10]Address fe80::eals:1ff:fe1b:d206%en0 port 8554
[tcp @ 0x104cf7d10]Address 10.1.4.1 port 8554
[tcp @ 0x104cf7d10]Interleaved list of addresses:
[tcp @ 0x104cf7d10]Address fe80::eals:1ff:fe1b:d206%en0 port 8554
[tcp @ 0x104cf7d10]Address 10.1.4.1 port 8554
[tcp @ 0x104cf7d10]Starting connection attempt to fe80::eals:1ff:fe1b:d206%en0 port 8554
[tcp @ 0x104cf7d10]Connection attempt to fe80::eals:1ff:fe1b:d206%en0 port 8554 failed: Error number -60 occurred
[tcp @ 0x104cf7d10]Starting connection attempt to 10.1.4.1 port 8554
[tcp @ 0x104cf7d10]Connected attempt failed: Error number -51 occurred
[tcp @ 0x104cf7d10]Connection to tcp://raspberrypi.local:8554?timeout=0 failed: Error number -51 occurred
LAVF_header: av_open_input_stream() failed


Exiting... (End of file)

Would you have an idea of what is wrong ?

PS : I used systemd-networkd to configure the pi as an access point but it doesn't seems to have an ip adress despite what is in 08-wlan0.network

pi@raspberrypi:~ $ cat /etc/systemd/network/08-wlan0.network
Name=wlan0
[Network]
Address=10.4.9.190/24
LLMNR=no
DNSSEC=no
MulticastDNS=yes
# IPMasquerade is doing NAT
IPMasquerade=yes
IPForward=yes
DHCPServer=yes
[DHCPServer]
DNS=84.200.69.80 1.1.1.1

Thank you.

2
  • There is no point asking yet another question until you get your network working.
    – Milliways
    May 16, 2023 at 22:44
  • it's working now and I got the stream working with cvlc. (the problem came from live555)
    – Steph
    May 22, 2023 at 9:52

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.