0

My Raspberry Pi4, running a standard Raspberry OS 32, can be found with its hostname on my LAN when it is connected with a cable. However, when connected only via WLAN, I cannot ping or ssh it with its hostname. Using the literal ipv4 address, it can be addressed. On my router, I have found that all devices having an ipv6 address, are discoverable from a PC. So I would like to turn on ipv6 on the WLAN interface, as it seems that the Pi is not requesting an address at the DHCP on the router. Can someone help how to do that or has an alternative solution? Thanks!

Peter

hl@raspi10:~ $ ip a

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000 link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00 inet 127.0.0.1/8 scope host lo valid_lft forever preferred_lft forever inet6 ::1/128 scope host valid_lft forever preferred_lft forever 2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN group default qlen 1000 link/ether dc:a6:32:f7:2e:b7 brd ff:ff:ff:ff:ff:ff 3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000 link/ether dc:a6:32:f7:2e:b8 brd ff:ff:ff:ff:ff:ff inet 192.168.1.93/24 brd 192.168.1.255 scope global dynamic noprefixroute wlan0 valid_lft 85868sec preferred_lft 75068sec inet6 fe80::dc55:91b8:8db6:93fc/64 scope link valid_lft forever preferred_lft forever

hl@raspi10:~ $ ip r

default via 192.168.1.254 dev wlan0 proto dhcp src 192.168.1.93 metric 303 192.168.1.0/24 dev wlan0 proto dhcp scope link src 192.168.1.93 metric 303

3
  • You have omitted ANY details from your question. What OS? How is networking configured? How are you trying to connect? What do ip a && ip r show.
    – Milliways
    Commented May 22, 2023 at 22:26
  • 1
    Your router may have AP isolation active. That prevents WiFi devices communicating. Disable that on the router's settings pages.
    – Dougie
    Commented May 23, 2023 at 9:13
  • thanks that is a good suggestion. My router does not support AP isolation but I will search further along that line.
    – drp
    Commented May 24, 2023 at 12:44

1 Answer 1

0

Update: I have replaced the router and now it is working again. Thanks @Dougie for pointing in the right direction.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.