1

I'm very confused, it's been a week since I'm encountering this problem. I can reach and connect to my raspberry from raspberrypi.local if I reboot or after shutting down and start again my computer but if I suspend, raspberrypi.local stops working. I can still continue to connect from IP.

I've installed avahi-daemon as other threads suggest and added to configuration allow-interfaces=wlan0 to make sure that nothing like doker could possibly interfere.

pi@raspberrypi:~ $ ping -c 1 raspberrypi.local
PING raspberrypi.local (192.168.1.117) 56(84) bytes of data.
64 bytes from 192.168.1.117 (192.168.1.117): icmp_seq=1 ttl=64 time=0.225 ms

--- raspberrypi.local ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 0.225/0.225/0.225/0.000 ms

To make things more confusing, I've tried to use all other computers that I can reach to try ping, and one never reaches the raspberrypi.local but works on its ip. The other seems to work always. (for context: I'm always trying from windows 7 or 10 to raspberry)

Could be the firewall?

pi@raspberrypi:~ $ sudo ufw status
Status: active

To                         Action      From
--                         ------      ----
22                         ALLOW       Anywhere
OpenSSH                    ALLOW       Anywhere
22/tcp                     ALLOW       Anywhere
5432                       ALLOW       Anywhere
22 (v6)                    ALLOW       Anywhere (v6)
OpenSSH (v6)               ALLOW       Anywhere (v6)
22/tcp (v6)                ALLOW       Anywhere (v6)
5432 (v6)                  ALLOW       Anywhere (v6)

Seems strange to me 'cause should not work always or never

I'm out of ideas, any suggestions?

Other info that can be useful: I'm using rasbian

pi@raspberrypi:~ $ cat /etc/os-release
PRETTY_NAME="Raspbian GNU/Linux 11 (bullseye)"
NAME="Raspbian GNU/Linux"
VERSION_ID="11"
VERSION="11 (bullseye)"
VERSION_CODENAME=bullseye
ID=raspbian
ID_LIKE=debian
HOME_URL="http://www.raspbian.org/"
SUPPORT_URL="http://www.raspbian.org/RaspbianForums"
BUG_REPORT_URL="http://www.raspbian.org/RaspbianBugs"
pi@raspberrypi:~ $ uname -a
Linux raspberrypi 6.1.21-v8+ #1642 SMP PREEMPT Mon Apr  3 17:24:16 BST 2023 aarch64 GNU/Linux
5
  • It's no just good just installing avahi-daemon you've also got to run it when the mDNS service stops responding.
    – Dougie
    May 23, 2023 at 12:13
  • @Dougie I'm not sure to understand correctly your comment, I've never use it before, but I'm pretty sure that avahi-daemon is running because systemctl status avahi-daemon says that is active, the ipv4 and ipv6 are registered and the host name is raspberrypi.local
    – Marco
    May 23, 2023 at 17:18
  • The other thing is, probably, is not a raspberry side problem because on one pc is running properly. I just tried to disable windows defender (without other ideas I will try anything) on the one that is not working but no response the problem continue to persist
    – Marco
    May 23, 2023 at 17:32
  • 1
    Run sudo avahi-browse -d raspberrypi.local to test whether avahi is responsive. That works on any Linux system. Windows should use mDNS by default (Win 10/Win 11).
    – Dougie
    May 24, 2023 at 8:41
  • WRT "is this a firewall?": unix.stackexchange.com/a/73782/25985
    – goldilocks
    May 24, 2023 at 13:19

1 Answer 1

0

You don't need to install anything and it is unclear what effect this would have. The standard dhcpcd already supports the functionality.

Try a fresh installation.

2
  • I know but I encountered the same problem with the native network manager so I've tried something else
    – Marco
    May 24, 2023 at 7:58
  • FYI: I've read recently that dhcpcd has been replaced by network manager (?) in the latest distro.
    – Seamus
    May 26, 2023 at 0:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.