0

Just installed PI OS LITE (64-BIT) on an SSD for my Pi 4B using the Raspberry Pi Imager (on a Windows machine). On first boot it keeps looping as follows:

  1. Rainbow splash screen
  2. "mmc1: Controller never released inhibit bit(s)" in top left of screen
  3. "Resizing root filesystem..."
  4. "Generating SSH keys" shows for less than 5 seconds
  5. "Fix PARTUUID" only shows for a fraction of a second (had to film my screen to be able to read it)
  6. "Rebooting in 5 seconds..."
  7. Screen goes black and we start back at 1

I tried reinstalling the OS to the SSD, but same result.

I had the 32-bit version of Pi OS Lite working earlier on the same SSD. Ran into compatibility issues, so trying to upgrade to 64-bit now.

I'm a noob when it comes to Pi's or Linux in general, so probably a mistake on my end. Anybody have an idea of what I'm doing wrong? If possible please explain in terms a Windows user can understand :)

7
  • step 5 may be a request for you to do something
    – jsotola
    May 27, 2023 at 17:40
  • 1
    Steps 1-6 are normal. I suspect your problem is the inability of the Pi to power your (unspecified) SSD. Why would you WANT to use a SSD for a Lite install?
    – Milliways
    May 28, 2023 at 0:01
  • What happens if you try using an sd card to boot? May 28, 2023 at 1:20
  • I use an SSD to run Docker on which I plan to run Home Assistant and some other services. I don't really like using SD cards as boot drives because I expect a lot of random writes and that makes SD cards die quick. I'll check if I can boot from another device though thanks
    – Martijn
    May 28, 2023 at 7:00
  • How many SD Cards have you seen fail? This is a Pi urban myth. I have cards > 10 years old and Pi that have been running for > 4 years.
    – Milliways
    May 29, 2023 at 7:15

1 Answer 1

0

@Milliways was right. It seems the Pi isn't always powerful enough to run a 2.5 inch SSD over an unpowered USB to SATA cable.

Now using a USB to SATA cable that has an external power adapter and I can boot into Pi OS with no problems.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.