0

i am stuck at playing the 4K even at less frame rates (25fps) on the HMDI 0/1 of my raspberryPi4 (8GB,Cortex A7 CPU,1.5Ghz CPUspeed) even after desirable settings of raspi4 and being supported by the moniter and HDMI cable. The issue is that it stucks at a frame but work OK(not good) when i decrease the speed to 0.5x or lower.

What i did till now is the following :

1.Tried different images ..current one is RaspberryPi OS 32 bit (recommended) (released on 2023-05-03) .

  1. Allowed the 4kp60 HDMI for port 0 via sudo raspi-config->Display Options-> Composite ->enable 4kp60 at hdmi0.
  2. Tried differnt groups and modes including the group 1 and mode 97 which is supported also in the moniter (the image of supported modes and groups is attached below.
  3. Tried many other edits in the config file as well including hdmi_enable_4kp60=1 ,hdmi_force_hotplug=1 , gpu_mem=256 (above 256 not supported i guess in my raspi4).
  4. Tried changing the hdmi cable as well to the official raspi4 cable that supports 4k.

Below are the RaspberryPi purchage link , config file ,and the supported groups and modes list .

Thanks for any help in advance.

.

RaspberryPi Link : https://www.amazon.in/Raspberry-Pi-8GB-Desktop-Computer/dp/B08B9XS3B6

HDMI cable link :https://www.amazon.in/India-Adapter-Ethernet-Compatible-Raspberry/dp/B08PW6W54V

Supported modes : enter image description here

Config.txt file :

#uncomment if you get no picture on HDMI for a default "safe" mode

#hdmi_safe=1

#uncomment the following to adjust overscan. Use positive numbers if console
#goes off screen, and negative if there is too much border

#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16


#uncomment to force a console size. By default it will be display's size minus

#overscan.
#framebuffer_width=1280
#framebuffer_height=720

#uncomment if hdmi display is not detected and composite is being output

hdmi_force_hotplug=1
hdmi_enable_4kp60=1

#uncomment to force a specific HDMI mode (this will force VGA)

hdmi_group=1
hdmi_mode=95

#uncomment to force a HDMI mode rather than DVI. This can make audio work in

#DMT (computer monitor) modes

#hdmi_drive=2

#uncomment to increase signal to HDMI, if you have interference, blanking, or

#no display

#config_hdmi_boost=4

#uncomment for composite PAL

#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.

#arm_freq=800

#Uncomment some or all of these to enable the optional hardware interfaces

#dtparam=i2c_arm=on

#dtparam=i2s=on

#dtparam=spi=on

#Uncomment this to enable infrared communication.
#dtoverlay=gpio-ir,gpio_pin=17
#dtoverlay=gpio-ir-tx,gpio_pin=18

#Additional overlays and parameters are documented /boot/overlays/README
#Enable audio (loads snd_bcm2835)

dtparam=audio=on

#Automatically load overlays for detected cameras

camera_auto_detect=1

#Automatically load overlays for detected DSI displays

display_auto_detect=1

#Enable DRM VC4 V3D driver

dtoverlay=vc4-fkms-v3d

max_framebuffers=2

#Disable compensation for displays with overscan

disable_overscan=1

[cm4]

#Enable host mode on the 2711 built-in XHCI USB controller.

#This line should be removed if the legacy DWC2 controller is required

#(e.g. for USB device mode) or if USB support is not required.

otg_mode=1

[all]

[pi4]

#Run as fast as firmware / board allows

arm_boost=1

[all]
gpu_mem=256
3
  • If you are using the kms driver the settings in config.txt have no effect. Try the Raspberry Pi Ltd. documentation.
    – Milliways
    Jun 2, 2023 at 22:38
  • You are obviously doing something you have not disclosed. "tvservice is not supported when using the vc4-kms-v3d driver"
    – Milliways
    Jun 3, 2023 at 11:41
  • @Milliways ,you are correct .By default it was 'vc4-kms-v3d' only but then i have changed it to 'vc4-fkms-v3d' which supports the 'tvservice'(source : github) .I forget to update it here .Thanks for pointing it out.But the issue persist with fkms as well.Can you suggest some alternate of this kms driver so that the config.txt changes will be reflected in the display as well(like the HDMI groups and modes) .Thanks a lot once again for replying, Jun 7, 2023 at 8:25

1 Answer 1

0

See https://www.raspberrypi.com/documentation/computers/config_txt.html#raspberry-pi-4-hdmi-pipeline

In particular "IMPORTANT When using the VC4 KMS graphics driver, the complete display pipeline is managed by Linux - this includes the HDMI outputs. These settings only apply to the legacy FKMS and firmware-based graphics driver.

I agree that the Raspberry Pi Ltd. documentation could be clearer but if you want to use a high resolution display use the Linux standard kms driver and appropriate tools. This requires you to configure resolution in the Screen Layout Editor (although this should automatically select the best resolution for your display).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.