1

The background is, we have 2 Raspberry Pi 3b boards, one in a fixed station and the second in a moveable station that can be any distance from 1m to 70m apart. The fixed station is connected to a TP-Link AC1350 router via a cable and the moveable station has a CSL WiFi dongle attached to one of the USB ports. Because of the distance, the moveable station wlan0 is not good enough to keep constant contact with the fixed station so the dongle was fitted to improve this and to use wlan1. I don’t know if the wlan1 has been working or not, I suspect not.

I have tried to replicate this on my own system at home.

My Raspberry Pi 3b at home is running the following:

PRETTY_NAME="Debian GNU/Linux 11 (bullseye)"
NAME="Debian GNU/Linux"    
VERSION_ID="11"   
VERSION="11 (bullseye)"    
VERSION_CODENAME=bullseye   
ID=debian    
HOME_URL="https://www.debian.org/"
SUPPORT_URL="https://www.debian.org/support"    
BUG_REPORT_URL="https://bugs.debian.org/    
Linux Kernel Version:  6.1.21-v8+

The CSL Dongle has a chipset of: Realtek RTL8191SU Driver for the 8191SU: USB Linux v2.6.2.2.0.20120403. Is there any way to make this dongle work with the Pi 3b even if it means re-installing the kernel back to v 2.6.


I'll add a little bit of context but as it's a weekend, I don't have any specifics and should be able too add exact model numbers etc during the week if required.

The main issue we have is that we need to use an external WiFi antenna with the RPI. The options for these on sale are very limited and we have been purchasing some at a whim as they don't list exactly which chipset they use etc on the listing.

Either way, this limitation has lead to us looking further into getting the adapter models mentioned in the question (CSL One) to work with the current os.

So far we have found that support for this driver was removed some kernel updates ago and to gain support, we could either downgrade the kernel (which we have successfully done, this then allowed us to install a driver with a script from github at the link below. And the adapter shows as wlan1, but unable to see any SSIDs or connect to wireless networks) or look at replacing the boards from RPI 3b to either 3b+ or 4 to look at our support and options for dongles there.

https://gist.github.com/kmonsoor/59c47d05d8c6cb397c15cd5eba7909e8

3
  • "I don’t know if the wlan1 has been working or not" neither do we because you haven't posted any diagnostics or explained how "the dongle was fitted" or configured.
    – Milliways
    Commented Jun 17, 2023 at 8:36
  • 1
    I've edited in additional details from the deleted answer. "they don't list exactly which chipset they use etc on the listing." -> True, but generally you can find the USB chip ID if you search around online. These are hexsting pairs such as 8087:0032 (vendor:device, lsusb also reports these, which is one of the ways they end up online, if you find a forum thread via brand name etc, look for that lsusb output), which can then be used to ID the chip itself online -- eg: linux-hardware.org/?view=search which will also give you some clues about linux support.
    – goldilocks
    Commented Jun 19, 2023 at 16:52
  • ...There is a bit of a gotcha here though in that some manufacturers will change the chip used but not the model number/name of the device (ie., it's possible to have two identical looking dongles that report different chip IDs). However, I don't think that is very common.
    – goldilocks
    Commented Jun 19, 2023 at 16:52

1 Answer 1

1

The last 2.6 kernel was released a dozen years ago; not positive but I think the first versions of Raspbian used a 3.x kernel, and that's as far back as the official Pi fork source tree goes.

Getting this going will likely be more work than the dongle is worth. The smart thing to do would be to make sure the dongle is compatible before you buy and install it.

That said, the existing rtl8xxxu may work for this. You haven't said anything about whatever problem you have is in detail. Is there an interface representing it? In that case, the driver is probably loaded, check via lsmod | grep rtl8xxxu.

If it isn't, and there is no interface, try loading it: sudo modprobe rtl8xxxu. An interface may then automagically appear. If not, you are out of luck with that dongle.

2
  • It looks like the Dongle problem has been solved, I found one in Silicon Valley. Panda PAU0B, it works straight out of the box and sets as wlan1. Now for the next problem, we cannot get rid of wlan0, everytime we set it as down, the system runs on wlan1 which is what we want but every night, the system has to be shut down to preserve battery power. On start-up the following morning, low and behold, back to the wlan0 and the signal dropping out again. we have looked and tried quite a lot of answers given on the net but nothing appears to work, if we kill wlan0 it takes out wlan1 as well. Commented Jul 4, 2023 at 16:08
  • Sounds like you've got a new question. If you post it, remember to include how you've configured networking, it should not be very hard to disable/leave down one particular interface. If you are using dhcpcd, the option is denyinterfaces (blacklist) or allowinterfaces (whitelist), these are right at the top of man dhcpcd.conf. You may also want to apply rfkill to wlan0: raspberrypi.stackexchange.com/q/73727/5538
    – goldilocks
    Commented Jul 5, 2023 at 14:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.