So first I tried to install the latest version of mongodb on my raspberry pi running Ubuntu server 22. But as I was going through other answer the hardware config of RPI3 does not support latest Mongodb version and hence I was getting error while starting the services.

hpoddar@raspberrypi:~$ sudo systemctl status mongod
× mongod.service - MongoDB Database Server
     Loaded: loaded (/lib/systemd/system/mongod.service; disabled; vendor preset: enabled)
     Active: failed (Result: core-dump) since Sun 2023-06-25 15:02:07 UTC; 1min 19s ago
       Docs: https://docs.mongodb.org/manual
    Process: 5153 ExecStart=/usr/bin/mongod --config /etc/mongod.conf (code=dumped, signal=ILL)
   Main PID: 5153 (code=dumped, signal=ILL)
        CPU: 169ms

Jun 25 15:02:04 ubuntu systemd[1]: Started MongoDB Database Server.
Jun 25 15:02:07 ubuntu systemd[1]: mongod.service: Main process exited, code=dumped, status=4/ILL
Jun 25 15:02:07 ubuntu systemd[1]: mongod.service: Failed with result 'core-dump'.

So I decided to downgrade the version by installing mongodb4.But Now I am getting the following error on pi.

hpoddar@raspberrypi:~$ sudo apt-get install -y mongodb-org=4.4.18 mongodb-org-server=4.4.18 mongodb-org-shell=4.4.18 mongodb-org-mongos=4.4.18 mongodb-org-tools=4.4.18
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 mongodb-org-mongos : Depends: libssl1.1 (>= 1.1.0) but it is not installable
 mongodb-org-server : Depends: libssl1.1 (>= 1.1.0) but it is not installable
 mongodb-org-shell : Depends: libssl1.1 (>= 1.1.0) but it is not installable
E: Unable to correct problems, you have held broken packages.

So I tried installing libssl1.1 on my RPI. But even that failed with the below error.

hpoddar@raspberrypi:~$ sudo apt-get install libssl1.0.0
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package libssl1.0.0 is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source
E: Package 'libssl1.0.0' has no installation candidate

On further research I found that its not possible to install libssl1.1 on RPI3

Ubuntu 22.04 uses libssl3, and thus libssl1.1 is deprecated at this point.

I do indeed have openssl version 3

hpoddar@raspberrypi:~$ openssl version -a
OpenSSL 3.0.2 15 Mar 2022 (Library: OpenSSL 3.0.2 15 Mar 2022)

Is there any working way to install mongodb on my pi now, I have followed so many steps, so many answers/resolutions but none worked for me.

  • You MUST run a 64-bit OS to run MongoDB.
    – Dougie
    Jun 27, 2023 at 6:58
  • I have 64bit OS Jun 27, 2023 at 8:18
  • I have compiled binaries for the Pi here that I haven't tried on a Pi 3 yet. You can give them a try. Jul 11, 2023 at 3:55


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.