Yesterday my raspberry pi 4 8GB was operating fine in a NAS setup where it was powered via the GPIO pins. I now took it out of the NAS case again and power it via USB-C. I use the official power supply and it was operating fine a few days ago with it. (I also tried other power supplies with the same result).

Now the machine becomes unresponsive a few seconds after boot:

Request timeout for icmp_seq 63
ping: sendto: Host is down
Request timeout for icmp_seq 64
ping: sendto: Host is down
Request timeout for icmp_seq 65
Request timeout for icmp_seq 66
64 bytes from icmp_seq=67 ttl=64 time=4.571 ms
64 bytes from icmp_seq=68 ttl=64 time=2.808 ms
64 bytes from icmp_seq=69 ttl=64 time=9.073 ms
64 bytes from icmp_seq=70 ttl=64 time=3.014 ms
64 bytes from icmp_seq=71 ttl=64 time=8.608 ms
64 bytes from icmp_seq=72 ttl=64 time=8.384 ms
64 bytes from icmp_seq=73 ttl=64 time=1.919 ms
64 bytes from icmp_seq=74 ttl=64 time=31.940 ms
64 bytes from icmp_seq=75 ttl=64 time=3.572 ms
64 bytes from icmp_seq=76 ttl=64 time=9.151 ms
Request timeout for icmp_seq 77
Request timeout for icmp_seq 78
Request timeout for icmp_seq 79
Request timeout for icmp_seq 80
Request timeout for icmp_seq 81
Request timeout for icmp_seq 82

If I skip the LAN cable and only use wifi, I have a ~90s time window, where I can ssh onto the machine. Everything seems normal until the pi interrupts the connection. Connecting the LAN cable seems to accelerate this process.

The only way to reconnect is to remove and reattach the USB-C cable.

How should I diagnose this? Could this be a hardware defect that occurred when I moved the Pi from case to case?

My openmediavault and home assistant seem to run without issues (for this short time frame). As the system boots up and everything is working fine for a few seconds, I believe a hardware defect is unlikely?

(I am running the Pi in headless mode and I currently do not have a monitor to attach to it).

PS: These are the last things in dmesg I see before it goes offline:

[    6.357177] cfg80211: Loaded X.509 cert 'sforshee: 00b28ddf47aef9cea7'
[    6.367179] cfg80211: loaded regulatory.db is malformed or signature is missing/invalid
[    6.458657] brcmfmac: F1 signature read @0x18000000=0x15264345
[    6.499780] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43455-sdio for chip BCM4345/6
[    6.500680] usbcore: registered new interface driver brcmfmac
[    6.565480] bcmgenet fd580000.ethernet: configuring instance for external RGMII (RX delay)
[    6.566018] bcmgenet fd580000.ethernet eth0: Link is Down
[    6.770899] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43455-sdio for chip BCM4345/6
[    6.776551] brcmfmac: brcmf_c_preinit_dcmds: Firmware: BCM4345/6 wl0: Nov  1 2021 00:37:25 version 7.45.241 (1a2f2fa CY) FWID 01-703fd60
[    7.272570] brcmfmac: brcmf_cfg80211_set_power_mgmt: power save enabled
[    7.574548] random: crng init done
[    7.574569] random: 5 urandom warning(s) missed due to ratelimiting
[    7.664133] audit: type=1400 audit(1688295382.339:2): apparmor="STATUS" operation="profile_load" profile="unconfined" name="lsb_release" pid=343 comm="apparmor_parser"
[    7.680443] audit: type=1400 audit(1688295382.359:3): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/bin/man" pid=344 comm="apparmor_parser"
[    7.680499] audit: type=1400 audit(1688295382.359:4): apparmor="STATUS" operation="profile_load" profile="unconfined" name="man_filter" pid=344 comm="apparmor_parser"
[    7.680541] audit: type=1400 audit(1688295382.359:5): apparmor="STATUS" operation="profile_load" profile="unconfined" name="man_groff" pid=344 comm="apparmor_parser"
[    7.705045] audit: type=1400 audit(1688295382.379:6): apparmor="STATUS" operation="profile_load" profile="unconfined" name="nvidia_modprobe" pid=346 comm="apparmor_parser"
[    7.705096] audit: type=1400 audit(1688295382.379:7): apparmor="STATUS" operation="profile_load" profile="unconfined" name="nvidia_modprobe//kmod" pid=346 comm="apparmor_parser"
[    7.720316] audit: type=1400 audit(1688295382.399:8): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/sbin/chronyd" pid=345 comm="apparmor_parser"
[   12.972098] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[   16.664880] uart-pl011 fe201000.serial: no DMA platform data
[   16.792257] Bluetooth: Core ver 2.22
[   16.792379] NET: Registered protocol family 31
[   16.792397] Bluetooth: HCI device and connection manager initialized
[   16.792427] Bluetooth: HCI socket layer initialized
[   16.792451] Bluetooth: L2CAP socket layer initialized
[   16.792494] Bluetooth: SCO socket layer initialized
[   16.821707] Bluetooth: HCI UART driver ver 2.3
[   16.821736] Bluetooth: HCI UART protocol H4 registered
[   16.821899] Bluetooth: HCI UART protocol Three-wire (H5) registered
[   16.822238] Bluetooth: HCI UART protocol Broadcom registered
[   17.015160] Adding 102396k swap on /var/swap.  Priority:-2 extents:1 across:102396k SSFS
[   18.595895] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[   18.595915] Bluetooth: BNEP filters: protocol multicast
[   18.595947] Bluetooth: BNEP socket layer initialized
[   18.687618] NET: Registered protocol family 38
[   18.792905] cryptd: max_cpu_qlen set to 1000
[   19.196834] NFSD: Using UMH upcall client tracking operations.
[   19.196865] NFSD: starting 90-second grace period (net f0000089)
meow@purr:~ $ Connection to closed by remote host.
Connection to closed.

I disabled the power saving mode for the WiFi but it seems to be reset after each boot cycle and it does not seem to be what is shutting down the Pi.

Here is my boot log obtained from openmediavault: https://pastebin.com/1PV68Sd7


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Browse other questions tagged or ask your own question.