1

Hey I now tried to figure out a solution for 3 weeks but now I am about to give up.

I want to connect my pi to the school network via LAN. The network infrastructure is very unusual but I was able to set up a connection on Android, iOS, OSX, Windows xp-7, Ubuntu and several other distributions, but on raspbian, I am just totally lost. Basic things about the network (lets say, the school name is school.ac:

Gateway     10.6.0.1
Hostname    10.1.0.2 (server name is s8.school.ac, you get 10.1.0.2 if you ping it)
Port        80
Netmask     255.255.248.0
DNS         10.1.0.5 
     and    10.1.0.20
DNS suffix  school.ac

When I set DHCP to connect to the LAN, I can ping servers. APT is not possible and the browser does not work, either.

The network/its proxy requires login to work so what I was trying is to set the credentials in the proxy host name in Midori: http:// user:pass@school.ac:80. Both user and pass only consist of lowercase letters and numbers.

On DHCP, when trying to access a page, it loads for ages if the address is valid and a download prompt is showing up, if I want to Open or download the file '' with the filetype '' that has, after saving, the content '' (so basically, a complete empty file without name or extension). I played around with taking other servers as proxies in combination with other (valid) usernames and password and a message like this pops up http://www.linglom.com/images/security/ISA/Customize-HTML-Error-Messages/1.png , but with 407 error code (authentication). I set up the /etc/bash.bashrc and the /etc/apt/apt.conf to use atp, but there, I get a 407, too.

If the address that I type into the browser is not valid (e.g. www.rertr.tr), that "This page cannot be displayed" shows up; this time with a 502 (gateway).. DNS???

So I manually entered the network details and DNS servers in the /etc/network/interfaces but now, whenever I type an address (valid or invalid doesn't matter) in the browser, the IIS7 splash comes up (http://www.biomedixincubator.com/welcome.png).

I hope there is some one out there willing to help me as I feel totally stupid right now. I guess it won't be very useful to give you guys my confs as I changed them now over 30 times and the results are equal/similar. I can't see any relation to anything in this situation, but just in case, here is the current state:

pat.conf
Acquire::http::Proxy "http: //user:pass@s8:80";
Acquire::ftp::Proxy "http: //user:pass@s8:80";

/etc/network/interfaces
auto lo eth0
iface lo inet loopback
iface eth0 inet static
address 10.6.0.116
netmask 255.255.248.0
network 10.6.0.0
gateway 10.6.0.1
dns-nameservers 10.1.0.5 10.1.0.20 #the nameservers made no difference; i didn't know they are in resolv.conf

resolv.conf
domain school.ac
search school.ac
nameserver 10.1.0.5
nameserver 10.1.0.20
#server 10.1.0.2 tried different things, but taken off as the browser couldn't resolve the names any longer (threw the error page directly instead of trying to load the page all day)
  • Should there be a space between http and : in the Acquire line? – Fred Mar 11 '14 at 8:00
  • I will try tomorrow if that changes anything. – user2161301 Mar 17 '14 at 12:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.