With the Raspberry Pi 3B, Raspberry Pi Imager, Ubuntu Server 64bit 23.04, for writing the SD card image, I tried the following Imager options:

At Image Customization Options Tried:

  • No configuration at all
  • Set Hostname: host
  • Set username and password: user, pssw, Disable SSH
  • Set username and password: user, pssw, Enable SSH Use Password Authentication

Hardware configuration:

  • Using a Mouse, Keyboard, Monitor, and LAN Cable connected

I gave a try to the "Raspberry PI Imager" from raspberrypi.com. It couldn't be easier than simply flashing an image from ubuntu.com. But I gave it a try.

After about 10 different trials, and 4 hours, the fancy "Raspberry Pi Imager", and waiting all those minutes you want to wait after the processes ended, the installation got stuck in the login prompt, and no possible configured user/pssw are accepted, with or without an SSH access, such as:

Username and Password Options Tried:

  • ubuntu ubuntu
  • ubuntu <Blank>
  • <Set Device Name> <Blank>
  • <Set Device Name> <Set Device Name>
  • <Set Username> <Set Password>
  • <Set Username> <Blank>
  • pi raspberry
  • pi admin

Error at SSH Prompt:

ssh [email protected]
[email protected]'s password:
Permission denied, please try again.

Error at Login Prompt:

Ubuntu 23.04 host tty1
host login:
Login Incorrect

For some absurd reason, the Raspberry Pi Imager is messing with the Ubuntu Image and making it non-functional.

Solution so far:

Hours lost giving a cent to a piece of crap.

Don't mess with the cute Imager. Go straight to the source ubuntu.com and burn it with BalenaEtcher (Not with Rufus!). Then SSH with ubuntu/ubuntu

Problem solved.

  • Ubuntu (like most Linux OS) requires you to create a user on first boot. The imager installs OS but the shortcuts are only for Raspberry Pi OS because the other OS don't have the code required to implement them. If you used a keyboard & monitor it would have worked.
    – Milliways
    Commented Jul 5, 2023 at 2:29

1 Answer 1


The problem is with the cute Raspberry PI Imager.

Don't use it if you go the Ubuntu way.

Go straight to the source ubuntu.com and burn it with BalenaEtcher (Not with Rufus!).

Then SSH with ubuntu/ubuntu.

Problem Solved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.