I bought a pair of used CM4s, and both seem to have a booting issue (presumably from the eMMC)

Steps to reproduce:

  1. I used the CM4 IO board to connect the CM4 via USB from my macOS laptop.
  2. Next, I used the usbboot repo, and the instructions in the official guide to flash and update the firmware and install the Raspberry Pi OS (tried both 32 and 64 bit).
  3. Note that I fit the jumper on nRPI_BOOT as mentioned while flashing.
  4. The green activity light blinks rapidly for the above steps, indicating everything to be "seemingly" normal.
  5. As expected, Flashing the firmware/bootloader gives me a green screen on a connected HDMI screen.
  6. Next, I power off the board, remove the USB connection, remove the jumper, and turn on the power as per the guide.
  7. Sadly, I do not see anything on the screen, and the green activity light doesn't come up.

As a different approach:

I also tried using usbboot to connect the device as msd in the GitHub repo instructions and then used the Raspberry PI OS GUI Imager / Installer to flash the OS to the eMMC. This process goes fine, but when I boot the CM4 after the flash, again no activity, nothing on the screen.

I think the eMMC is fine because I can add/remove files with macOS finder (file browser). The data persists between physical disconnections.

I can reproduce this on both my CM4s which are 4 GB RAM and 32 GB eMMC versions. I have also tried different carrier boards with the same results.

What should I do? Any help is much appreciated.

1 Answer 1


There is no fix!

It took a while, and I think the CM4s are gone for good. The CM4s are handed over from one buyer to another before ending up with me.

The OTP (One-time programmable) chip has been locked with private keys as a security measure in these steps. These modules are considered "industrial-grade," and only operating systems "signed" by those who used the keys to lock the OTP can boot.

It's a shame that a perfectly OK piece of hardware is just e-waste now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.