0

Hi I am trying to run the command: sudo ir-keytable -v -t -p all but I get the error in posted. Also, I get "Protocols for device can not be changed". This is to test the input run for the ir remote I want to use for my project. I have successfully installed the ir-keytable. I am using raspberry pi 4B. How can I resolve this issue?

2 Answers 2

0

What version of the Raspberry OS were you using? I am having the a similar issue with ir-keytable on Bookworm. I have configured gpio-ir in /boot/firmware/config.txt

tail -1 /boot/firmware/config.txt
dtoverlay=gpio-ir,gpio_pin=25

The hardware and wiring is proven as the same configuration has been with Bullseye and works perfectly.

sudo ir-keytable -v -t -p  rc-5,rc-5-sz,jvc,sony,nec,sanyo,mce_kbd,rc-6,sharp,xmpir-keytable
Found device /sys/class/rc/rc1/
Found device /sys/class/rc/rc2/
Found device /sys/class/rc/rc0/
Couldn't find any node at /sys/class/rc/rc0/lirc*.
Input sysfs node is /sys/class/rc/rc0/input0/
Event sysfs node is /sys/class/rc/rc0/input0/event0/
Parsing uevent /sys/class/rc/rc0/input0/event0/uevent
/sys/class/rc/rc0/input0/event0/uevent uevent MAJOR=13
/sys/class/rc/rc0/input0/event0/uevent uevent MINOR=64
/sys/class/rc/rc0/input0/event0/uevent uevent DEVNAME=input/event0
Parsing uevent /sys/class/rc/rc0/uevent
/sys/class/rc/rc0/uevent uevent NAME=rc-cec
/sys/class/rc/rc0/uevent uevent DRV_NAME=cec
/sys/class/rc/rc0/uevent uevent DEV_NAME=vc4-hdmi-0
input device is /dev/input/event0
/sys/class/rc/rc0/protocols protocol cec (enabled)
Opening /dev/input/event0
Input Protocol version: 0x00010001
Protocols for device can not be changed
Error: unable to attach bpf program, lirc device name was not found
Testing events. Please, press CTRL-C to abort

Any ideas?

1
0

The second problem in this post is SOLVED. I upgraded the kernel to Linux bookworm32 6.1.65-v8+ by running: sudo rpi-update After a reboot the IR remote control worked perfectly. Also remember that the dtoverlay must be added to /boot/firmware/config.txt and not to /boot/config.txt

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.