0

I am using Raspberry Pi 3B+. I am making my printer - Brother DCP-T300 wireless using Raspberry Pi. But, I am not able to make it run.

In the option of choosing the make, Brother was not present.

So, I randomly chose HP, and then chose the model HP color Inkjet. It does not work.

I tried to find brother at other places, and tried to find it's PPD file, but I am not able to find it. It is not present on the official site of Brother.

What should I do? I am running test prints, but they are not being printed.

Options to choose the model

3
  • I found the PPD on brother website by searching for cups ppd brother dcp-t300 Jul 29, 2023 at 23:12
  • Hi, I am unable to find the ppd directly. I found the website from which you can create a brother ppd. Is that what you are referring to? Jul 31, 2023 at 4:08
  • I found that in the downlaods of the brother website, there was cupswrapper package, i installed that, and now the printer's make, and model is visible. Thanks! Jul 31, 2023 at 4:41

1 Answer 1

0

Brother provides printer drivers for the x86 architecture, not for ARM. For the Pi, which is ARM, Brother does not provide printerdrivers.

You may have a look at https://github.com/alexivkin/brother-in-arms; maybe that helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.