0

I have got a Huawei E220 modem and I connect it with sakis3g. Recently I switched to a 4G network with 40Mb/s speed.

However, with this modem I still get only 2Mb/s, because I think I connect through 3G. I suppose that this model simply doesn't support 4G.

I can get a Vodafone K5150 modem, but I'm not sure about the drivers for RPi. I have found the information that "the product carries the linux drivers", but I'm not sure how much are the drivers unversal for all distros.

So the question: Can I use K5150 modem easily with RPi? And can I use sakis3g for connecting to a 4G network?

8
  • It seems to be possible. Have you read this topic at the official Raspberry Pi forum?
    – M. Mimpen
    Mar 12, 2014 at 10:24
  • @M.Mimpen Now I went through it very briefly (which is the only thing that can be done since forums are so bad in information structure). Well, I decided to simply get the Vodafone dongle (it cost EUR 3 and 1 hour in the ISP's office), I'll see later if it works well. They provide an automatic configurator for linux which works on my Fedora 12.
    – yo'
    Mar 12, 2014 at 13:30
  • 1
    It would have been nice if you tried it out and could form an answer on this Exchange for future users... :)
    – M. Mimpen
    Mar 12, 2014 at 13:38
  • @M.Mimpen I plan to do that if I succeed (disclaimer: I have ~30k SE rep so I know well how the sites work ;) )
    – yo'
    Mar 12, 2014 at 13:40
  • @M.Mimpen I reduced the problem into a problem of running x86 binaries on RPi :-/
    – yo'
    Mar 12, 2014 at 19:59

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.