1

I'm trying to connect my Raspberry Pi 3B with my SIM 900A Mini GSM module ( https://acoptex.com/wp/wp-content/uploads/2019/12/SIM900Apro3.jpg ).

I'm facing the following issues ( maybe they are related, maybe not )

  1. GSM module doesn't work.

    I've put in a 4G sim card, connected the antennae, and then connect the VCC and the GND to a battery using the JP2 connector. I've read that after around a minute the GSM module should be ready to start accepting calls but I've observed it doesn't in my case.

    The D5 Status LED is continuously lit up ( no blinking ) and the same is true for the D6 Netstatus LED ( Although it switches for around a second after 14-20 seconds ). I've read that there should be a 3s ON/ 1s OFF blinking of the D6 Netstatus LED after it connects to the network.

  2. Unable to send messages to the GSM module through Raspberry Pi

    After setting up the GSM module as stated above, I've connected Raspberry Pi Pin 14 (GND) to the SIM 900A GND ( the one present with the RS 232 Serial Port ). I've connected Pi Pin 8 (TX) to 3VT and Pin 10 (RX) to 3VR ( Previously tried connecting the Pi pins to 5VT and 5VR respectively, but that also didn't work and I read somewhere that Pi requires 3V to work ).

    Next, I powered on the Raspberry Pi and tried sending the 'AT' command on /dev/ttyS0 using the code below.

import time
import serial
import os, time
cmd=''
ser = serial.Serial('/dev/ttyS0', 9600, timeout=1)
ser.reset_input_buffer()
while True:
    smd=input("please enter a command: ")
    smd=smd+'\n'
    smds=smd.encode('utf-8')
    ser.write(smds)
    print("smd value is:",smd)
    line = ser.read(10).decode('utf-8').rstrip()
    print(line)

It's expected that I should get an OK back. But I just get an empty string back.

Is there something I'm missing? Do I need to power up the SIM 900A some way before its ready to work?

I also couldn't find good documentation for the SIM 900A Mini board. If someone has links to it, could you please share?

1
  • I get a similar issue (except I'm using /dev/ttyAMA0). My "D5 Status LED is continuously lit up (no blinking)"; however, my "D6 Netstatus LED" is steadily blinking (~½ sec. on, ½ sec. off). I also, like you, get no response (empty string) from AT.
    – Geremia
    Jan 9 at 3:32

2 Answers 2

-1

You need to swap RX and TX. One ends TX is connected to the other ends RX.

Mind you the Pi UART may have been destroyed if you connected it to 5V.

1
  • Mine works when I do a loopback test (connect the RX and TX with one jumper wire).
    – Geremia
    Jan 9 at 3:33
-1

In your picture, it is written that the power supply is a 5V, 2A lithium battery. Are you really using that? If so, please check your battery voltage and current. Please Keep in mind that you cannot use the GSM modules if you power the raspberry pi/ Arduino and the GSM module with the same power supply. They always need a separate 5V,2A power supply.

If you really ever need, you can make a 5V,2A breadboard power supply like this one

2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.