0

So from what I have been googling, it sounds like it could be the SD card, but it is brand new and no other applications detect an error with it. Hopefully someone here can help me confirm.

I bought a brand new 64gb SD card and the Raspberry Pi 4 that comes with a 32gb SD card preloaded with Rasbian desktop. The system boots up fine using the 32gb preloaded card, but not when I use the new 64gb one.

After flashing an image to the card, inserting it, and starting the Pi, it looks pretty normal. Blue screen with the off-gray text box that flashes a few messages like "...Depending on the size of your drive, this could take a few minutes" and "Generating SSH Keys".

Then, all of a sudden, it flashes the message "Fix PARTUUID", then black screen. A ton of terminal text zooms by, before stopping with the following line:

# wall of text ...
EXT4-fs (mmcblk0p2): ext4_check_descriptors: Block bitmap for group 255 overlaps superblock
EXT4-fs (mmcblk0p2): ext4_check_descriptors: Inode bitmap for group 255 overlaps superblock
EXT4-fs (mmcblk0p2): ext4_check_descriptors: Inode table for group 255 overlaps superblock
EXT4-fs (mmcblk0p2): ext4_check_descriptors: Checksum for group 255 failed (27546!=0)
EXT4-fs (mmcblk0p2): failed to initialize system zone (-117)
EXT4-fs (mmcblk0p2): mount failed
# some more text...
---[ end Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(179,2) ]---

I have tried many times to reformat the SD card and flash a new/different OS to the card using different methods. Each results in a slightly different failure state.

Here is what I have tried:

  • Both complete and quick formatting of the SD card before writing any image.
  • Writing Ubuntu desktop, Ubuntu server, and Rasbian desktop (all 64 bit versions).
  • Using the sdcard.org formatter and the built in windows one.
  • Pre-formatting the SD card to Fat32 before writing an image (Etcher and RPI imager).
  • Downloading the latest Rasbian desktop 64 bit image and writing it (using both Etcher and RPI imager).
  • Inserting a blank SD card and letting the Pi download the latest image.

Depending on the permutation (full vs quick formatting, the OS, the imager used), I will end up in one of two failure states:

  1. The one described at the start of this question
  2. I make it past the "first time set up" questions for the OS, it does a standard reboot, but then it enters a never ending reboot loop (don't even see any text written to the screen before it restarts again, then repeat).

Does anyone know what I am doing wrong, or have any other tests I could run?

Note that I do not have a Linux box I can plug the card into and check.

Thank you for your help.

2

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.