-2

I use a 4GB raspberry pi 4B. Recently, I switched to Ubuntu, and it had been working fine, until one day, I booted it up and the screen was black. Sometimes a glitched Ubuntu loading screen appears before a black screen, only containing a blinking text cursor which I can’t interact with. I’ve tried using terminals with alt + f(n), but, for some reason, I can’t write out files that allow to resolve the issue. I’ve tried modifying some lines in the config.txt file, like hdmi_safe, hdmi_force_hotplug and hdmi_force_output, but nothing works. Can anyone please help me?

5
  • 1
    Just restore from your backup.
    – Milliways
    Commented Sep 8, 2023 at 22:37
  • If you can see a cursor, then it's unlikely a HDMI config change will fix anything, since HDMI is not broken. did you try Ctrl+Alt+f(n) instead of just Alt+f(n) as for until one day ... what happened the previous day? probably some Ubuntu update? Commented Sep 8, 2023 at 23:35
  • Ctrl+Alt+f(n) seems to do the same thing. However, when I did that after holding the up and down arrows while it loaded, the Ubuntu loading screen appeared. Then, an error popped up saying “[FAILED] Failed to start snapd.failure.service - Failure handling of the snapd snap”. As for the day before, I had been running some terminal commands, specifically opencv build, and changing some Geany settings. I don’t know whether it got updated, but I reckon I just unplugged it. Commented Sep 9, 2023 at 9:12
  • 1
    this site is not a forum ... please add all information to the question ... do not use comments
    – jsotola
    Commented Sep 12, 2023 at 1:07
  • The question doesn't seem to be editable, and I didn't believe that what I'd done before would be so important, since many people reported having this problem right after Ubuntu updates. Commented Sep 15, 2023 at 14:13

1 Answer 1

0

I managed to resolve the problem. Given that I was unable to rewrite files, I started by doing sudo mount -o remount,rw /. Then, I did sudo dpkg-reconfigure gdm3 and sudo service gdm3 restart. Immediately after that, my desktop appeared. However, now I have to do this every time I want to boot up my Raspberry Pi, so if anyone knows how to solve the rest, that would be helpful.

1
  • I was trying to make an autostart file and when I rebooted, a black screen with the mouse cursor. I tried many different keyboard with no results. When I right clicked with the mouse, several options appeared, one was a terminal, which I used to correct the autostart file.
    – bstipe
    Commented Sep 16, 2023 at 22:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.