1

I'm new to RPi. I'm trying to follow the instructions found at: http://xmodulo.com/2013/11/write-raspberry-pi-image-sd-card.html

I've downloaded the zip, extracted it into a temp directory, and now I'm trying to run the dd command like so:

jj@devbox:/$ sudo dd bs=4M if=/tmp/wheesy/2014-01-07-wheezy-raspbian.img=/dev/sdb
dd: opening `/tmp/wheesy/2014-01-07-wheezy-raspbian.img=/dev/sdb': No such file or directory

What I've done so far:

  1. I've tried running "gksudo gparted" to confirm the name of the sd card. From the drop down list, I see that the SD card is called "/dev/sdb". When I select the SD card from the drop down to get details on it, under the Partitions section, I see two lines:

    line 1 - unallocated partition, unallocated file system, size 4MiB

    line 2 - /dev/sdb1, fat32 file system, 3.39GiB

I've tried the dd command using both /dev/sdb and /dev/sdb1.

  1. I've made sure that the SD card is unmounted before I run the dd command. I launch nautilus and right click on the drive... and I ensure that "Mount" is an option. I'm assuming if it is, it means that it's currently unmounted.

Any suggestions would be appreciated.

Thanks.

1

you were missing the of=

sudo dd bs=4M if=/tmp/wheesy/2014-01-07-wheezy-raspbian.img of=/dev/sdb
  • doh! I just tried it and yes, it seems to be getting a little further. Thanks. I'll accept your answer as soon as the site lets me – dot Mar 13 '14 at 17:23
  • We've all been there. Good luck – Gerben Mar 13 '14 at 17:25
1
sudo dd bs=4M if=/tmp/wheesy/2014-01-07-wheezy-raspbian.img=/dev/sdb

That should be:

sudo dd bs=4M if=/tmp/wheesy/2014-01-07-wheezy-raspbian.img of=/dev/sdb

The site you linked does have it correctly:

sudo dd bs=4M if=/path/to/image of=/dev/sdc

It's important to pay attention and at least have a look at manual pages (man dd) when you do this stuff so you have a bit of understanding of what's going on.

  • @goldilocks... I misinterpreted the "of". I kept reading it as a part of the image name. But thanks for the reminder to check the man pages. – dot Mar 13 '14 at 17:35
  • Totally understandable ("image of", lol -- whoops), like Gerben says we've all been there. What should tip you off in this case is the error message with the wrong filename. – goldilocks Mar 13 '14 at 17:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.