2

I have a problem which I can not solve.

I have a Raspberry Pi 4B with 4GB RAM. This worked until this morning without problems with a USB 3.0 stick from Transcend and with 64-bit Bullseye PiOS (desktop).

I then formatted the stick and reinstalled the PiOS with RPI-Imager on macOS 14.0. Since then, the Raspberry Pi no longer boots into the desktop.

Here's what happened:

  1. Rainbow splash screen
  2. mmc1: Controller never released inhibit bit(s) at the top left of the screen.
  3. Resizing root filesystem...
  4. Generate SSH key is displayed
  5. Fix PARTUUID is displayed for only a fraction of a second (I had to film my screen to read it)
  6. Restart in 5 seconds...
  7. The screen goes black and we start again from 1

Sometimes you can see the Raspberry Pi image for the desktop version which is displayed at normal system startup, for a second or so.

I then took another Raspberry Pi 4B with 2GB RAM for testing. This one shows the same problem all of a sudden (and never before).

What I have tried so far:

  1. Installed a fresh USB-Stick with the RPI-Imager -> same problem
  2. Deleted partitions from all USB-Sticks/SD-Cards, created MS exFAT partition and installed them with the RPI imager -> same problem
  3. Using the RPI imager, updated the bootloaders on both Raspberry Pi's. Both USB boot/SD card boot and SD card boot only. The process seems to work properly, but there is no green screen at the end, but the green LED is flashing constantly
  4. SD card installed with PiOS -> same problem
  5. 3(!) other power supplies (5V/3A, 5V/2,5A, 5V/4A) tested -> same problem
  6. Created USB-Sticks / SD-Cards on a Windows 11 computer -> same problem
  7. USB-Sticks / SD-Cards installed with Win32DiskImager (64-Bit Bullseye PiOS AND 32-Bit Bullseye PiOS) -> same problem

I'm sorry to say that I'm at a loss. Does anyone have an idea? Thanks a lot.

9
  • I'm confused - so you have 2 Pi4's and they both get stuck in boot loops - is that the right? Have you downloaded the latest Bullseye dated May 3rd 2023? Have you previously used Bullseye on these Pi4's?
    – CoderMike
    Oct 3, 2023 at 17:58
  • Have you copy and pasted the following? raspberrypi.stackexchange.com/questions/143274/…
    – CoderMike
    Oct 3, 2023 at 18:24
  • Does it work if you use a SD Card? Erasing/reformatting is just a waste of time because the installer overwrites the media.
    – Milliways
    Oct 3, 2023 at 21:52
  • So you never can complete the "First boot sequence". 1. Check the LED blink pattern and compare it to support.pishop.ca/article/… 2. Check the MD5 sum of the image you create the boot media from (It has been reported that corrupt downloads can cause erratic behavior)
    – MatsK
    Oct 4, 2023 at 9:06
  • 1
    @MatsK Thanks for the link. I receive 3 short blinks which is a "Generic failure to boot". I cleaned the USB-Sticks and SD-Cards with Diskpart from Windows and created an exFAT pertionin prior installing a fresh Bulleye Image.
    – Peter
    Oct 4, 2023 at 10:50

1 Answer 1

1

My PI's are again working as expected. Long story short, I deleted the pre-configuration within the RPi-Imager and everything worked fine with an SD-Card after activating the config option hdmi_force_hotplug=1.

I replaced the pre-configuration and everything worked fine with the SD-Card again.

After this success, I installed the image to my earlier mentioned USB-Stick (with hdmi_force_hotplug=1). The first thing I saw was the message mmc1: Controller never released inhibit bit(s) on the screen. After 5 seconds or so, the initial boot process started. After finishing this process, my RPi performed a restart, did "something" and rebooted again. After the last boot, the RPi booted into the PiOS Desktop.

What I've learned is that the message mmc1: Controller never released inhibit bit(s) " seems to be irrelevant and is only seen during USB-Boot.

Furthermore it's new for me that the actual Bullseye Image reboots twice after initial setup. All later startups do not reboot and are quicker.

And last but not leased during USB-Boot it seems that there is no activity to see on the green LED while loading the Desktop. While using an SD-Card you can see constant LED flickering until the Desktop has loaded.

Thanks for your support.

2
  • @MatsK Thanks for reformatting my answer. :-)
    – Peter
    Oct 5, 2023 at 11:25
  • Your welcome, and I appreciate that you posted your experiences
    – MatsK
    Oct 5, 2023 at 16:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.