3

So I've been trying to get SFTP to work since it's my only option consider downloading is bugged, screenshot from putty: http://puu.sh/7upSc.png The download for that java SDK just stops at some random point forever but downloads fine on my PC.

Anyway, unless you know a solution for that, I need to fix the SFTP at least to move this file across. I know my settings are correct:

hostname: 192.168.1.133
port is 22
user: pi
pass: *********
Protocol: SFTP;

and these settings do allow me to SSH into it :/

Despite that, Filezilla is throwing this back at me.

00:52:04 Status: Connecting to 192.168.1.133...

00:52:04 Response: fzSftp started

00:52:04 Command: open "pi@192.168.1.133" 22

00:52:25 Error: Network error: Connection timed out

00:52:25 Error: Could not connect to server

Also forwarded port 22 to the pi and that's no help.

Just tried setting up as a web server and it's still not connecting

OK SO, fixed. Well the SFTP is still buggered but in order to get the java download (Was trying to grab an older version anyway...) I had to close Steam and Skype. I don't understand why but as soon as someone sent a message on either it would slow down and stop the download very quickly.

  • It sounds like whatever is causing the Java download to fail is what's causing the SFTP problems as well. Maybe you've got a dodgy network cable? – Fred Mar 14 '14 at 8:14
3

I found this post searching for the same exact problem. I could connect to the Pi with Putty over SSH, but when I would try to connect with FileZilla, I would get the timeout.

I noticed when I would log on through Putty, the user prompt was fast, but the normally fast password prompt would take - about 20 seconds or so.

So I googled a bit, and found a suggestion for the slow SSH logon.

The solution was to edit the /etc/ssh/sshd_config

I uncommented the listen to 0.0.0.0 line, and I added the useDNS=no to the end of the file.

I rebooted, the SSH logon was back to fast, and lo and behold FileZilla connects instantly.

2

if you already have the file on your PC, and I assume you have a windows PC (?), then the easiest way to get this file to your raspberry pi is probably to use winscp (you can get it here)

winscp works like a regulat ftp client but uses SSH protocol, so you do not have to setup an sftp server on your pi.

in winscp just add a new server, and ad the host: 192.168.1.133, username: pi and password: raspberry and simply drag and drop the file accross

on a side note: after you have done this, you should change your password :)

  • Looks like WinSCP didn't work either, still times out with those details despite PuTTy connecting just fine. Not going to be able to set it up with an ethernet cable unfortunately by the way. Going to try setting it up as a web server for starters and connecting via regular FTP, I'd really like to know what's going on with the SFTP and that Java download though... – Ash Mar 14 '14 at 12:21
  • when you scp it over, where on the pi do you try to put it? try to put it on your /home/pi folder if not tried already – Sverre Mar 14 '14 at 14:01
1

I had the same issue and I took ages to found out. As livewithapes said, the problem is in the Raspberry pi 3, because the SHH is disabled by default.

You can solve that problem manually from the desktop:

Rasberry pi 3 desktop:

  1. Launch Raspberry Pi Configuration from the Preferences menu
  2. Navigate to the Interfaces tab
  3. Select Enabled next toSSH
  4. Click OK

Alternatively, in the Terminal:

  1. Enter sudo raspi-config in a terminal window
  2. Select Interfacing Options
  3. Navigate to and select SSH
  4. Choose Yes
  5. Select Ok
  6. Choose Finish

Source: https://www.raspberrypi.org/documentation/remote-access/ssh/

0

I had the same problem, the issue was SSH was disabled in Raspberry Pi Configuration.

Go into Raspberry Pi Configuration and enable SSH.

Voila!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.