0

For starters, this is the exact product I purchased. I'm not from the US and I have little access to RPis, so I bought it during my vacation (around Dez 20).

It's a RPi model 4B, 8GB and what seemed a pretty decent starter kit (although the shortage made it more expensive...), with a good 32GB microSD card included and a pretty good vendor.

BTW, this is the included fan. Doesn't look great, but at least I triple checked that I plugged it correctly on the proper pins.

Any kind of deadline I had with Amazon or with the vendor seem to have ended in March.

So, that's my hardware. From day 1 (or day 0, or even day -30) I intended to use it as a multimedia server. This meant I would be using OMV, so on Raspberry Pi Imager, I immediately chose Raspberry Pi OS Lite, 64-bit (OMV is headless only).

Everything has been working perfectly as expected, although I had a few fights against Docker and so on, but basically, my Pi + HDD dock + Router were plugged to an extension (which actually has a fuse) 24/7 flawlessly since January.

A few days ago, the Pi simply stopped working overnight. I recall watching something on Plex around 00:00 and later, by 13:00, the server was inaccessible. I started checking from ground up: routers, outlets, loose cords, extensions, everything. I wouldn't even imagine the issue was the Pi.

I noticed the pattern mentioned on the subject: 3 long blinks, 3 short ones (3L/3S) on the green LED. I then started researching a lot for answers to what it seemed to be a "I2C error - Pi 4". I've found no solution anywhere, not even on the forums. It also seemed to be something of a non-documented yet issue.

I'm not 100% on all the testing I did, but I checked the microSD card usage and health, even boot gParted to dig into it, it seemed to be working perfectly fine for anything else. My other microSD is 128GB, both on the same class, but the 128GB seems faulty, I couldn't really test with it. But still, I also tried booting from a thumb drive, tried the Full OS versions (hoping for any error codes on screen, but I had no signal at all), as well as the Bootloader utility and, finally, I used my set of anti-static brushes and isopropyl alcohol (all suited for working on PCBs) to try to remove any possible residue, fur, or whatever could have managed to somehow enter my Pi's case.

No luck with any of the tests. Also, I should add that the blinking pattern happens both with or without a microSD (or other storage) inserted.

Oh, and I also tried removing the fan, rechecking its connections and so on. It still works (aka gets power), but everything was the same with or without it.

I'm guessing things are pointing towards hardware failure and, from my research, it may be non-repairable at all. If that's the case, I'm really, really screwed. But maybe it's something one can manage to (or have a technician) fix.

What do you think, any hope for me?

Thanks for your input!

6
  • @JaromandaX Yes, I stumbled upon that while researching. The question doesn't really have an answer. Or at least not an accepted or high voted one. As this was already old and the issue remained lacking more detailed info on official sources, it seemed to me that a new question would be valid. Oct 8, 2023 at 7:22
  • The answer states: As far as I am aware that is a permanent error. There is no fix. - the only other mention I've seen of this error was on a CM4, and the suggestion was that the power supply may be lacking. Oct 8, 2023 at 8:01
  • So, by your own words, we have an "as far as I am aware [..,] There is no fix", and a "the only other mention I've seen", in a 1 year old question that's not particularly descriptive and might even be about different hardware. As I stated from the start, I'm also under the impression that it's a hardware, non-fixable issue. Yet, "only other mention", incomplete documentation (this blinking pattern was missing in a few references) and outdated troubleshoot makes me think this is at least fit for a (reasonably) similar question. Oct 8, 2023 at 18:07
  • "If that's the case, I'm really, really screwed." Yeah - you might be. You bought from an Amazon reseller (never a good idea), so you don't know if your RPi was a genuine RPi, or a cheap, China knock-off. Here's what I don't see in your "kit": 1) power supply specs, or an "official" RPi pwr supply, 2) any mention of what brand of SD card you're using. If it's a genuine RPi, those two items (PS, SD) are critical to proper function. If I were you, I'd get a good quality PS, a name-brand SD, then load RPiOS Lite on SD to check if it boots. And never buy fm an Amazon reseller.
    – Seamus
    Oct 13, 2023 at 20:29

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.