0

I installed bookworm a couple of days ago and today I was at the university when I realized that I couldn't connect via ethernet cable. Using TigerVNCViewer gives me this message:

Failed to connect to "raspberrypi.local"

unable to connect to socket: No connection could be made because the target machine actively refused it (10061)

The Rasp's LEDs are on

Using ifconfig gave this in the terminal which looks like there is no IP adress:

enter image description here

Should I go back to Bulleye?

I can connect TigerVNCviewer via WLAN with raspberry at home. But I won't be able to make a connection at other places since I don't have a portatil screen.

Any Ideas?

EDIT: I was able to run sudo nmtui

and I disable IPv6. But How can I enable IPv4 :

The main goal is to use my raspberry pi and laptop with ethernet cable when there is no WIFI available.

I can use TigerVNC viewer to connect my laptop and raspberry pi when I'm home using my wifi because when installed bookworm at home, I was able to provide my password and wlan name to the raspberry pi using a TV as screen.

Now, If I leave my house I want to connect to my raspberry pi with my laptop with no wifi let's say at mall. Even if there were wifi I would still need a screen to set up the wifi password let's say starbucks.

enter image description here

4
  • "ifconfig gave this in the terminal which looks like there is no IP adress" -> Yes there is, it's an IPv6 address starting with fe80::.
    – goldilocks
    Oct 25, 2023 at 15:44
  • I have not upgraded yet but someone here observed that the networking service used by default on bullseye (dhcpcd) was replaced in bookworm with NetworkManager. It's pretty well documented online, I think, since it has predominated on various big linux distros for a decade or so.
    – goldilocks
    Oct 25, 2023 at 16:20
  • @goldilocks I will look if there is anything about connection between laptop and raspberry pi with ehternet cable. Thanks
    – ed190
    Oct 25, 2023 at 20:00
  • @goldilocks I made an update and edit. I ran sudo nmtui to disable IPv6
    – ed190
    Oct 26, 2023 at 9:15

1 Answer 1

-1

Your Pi does not have an IP address issued by your network.

It does have an IPv6 link address (which is allocated by the Pi) but these only work on a link and not all services work over a link.

Your problem is with the network connection (you have provided no details) so you should investigate this.

VNC on Bookworm seems to have many problems and is poorly documented. Try some other protocol.


Your question is misleading.

You now state "But when I disconnet(sic) the cable from the router and now I connect the raspberry pi with the laptop with the cable, the Ip disapears" - this is hardly surprising as there is no longer a DHCP server. In this case (provided you have a suitable cable and compatible interfaces) you will only have a Link-local address.

4
  • I made an edit on my post. I ran sudo nmtui and I disable IPv6 but IPv6 doesn't have information
    – ed190
    Oct 26, 2023 at 9:32
  • You seem to be fixated on disabling/enabling things. If you connect the Pi (without ANY changes) to a router with a suitable cable it will get addresses allocated by the DHCP server on the router.
    – Milliways
    Oct 26, 2023 at 10:15
  • I did already what you said. I got the IP adress from the router and Internet. But when I disconnet the cable from the router and now I connect the raspberry pi with the laptop with the cable, the Ip disapears. So it didnt work because I get the same message: ' unable to connect to socket: No connection could be made because the target machine actively refused it (10061) '
    – ed190
    Oct 26, 2023 at 11:13
  • I will try to get the ip adress from windows ethernet adapter in ipconfig and see if I copy the adress from ethernet and put it somehow in raspberry works.
    – ed190
    Oct 26, 2023 at 11:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.