0

I have a problem with my Arducam OV5647 M32076M20. It simply will not work unlike the other generic rpi camera I have on the same code. I am unsure if there are any other dependencies that I need for this.

Things to note:

  • vcgencmd get_camera returns supported=1 detected=1, libcamera interfaces=0

  • I am using OpenCV and tkinter and its basically just a simple program that shows what the camera sees when its turned on. It works on other camera except the one I've shown

  • I have a script that detects camera with cv2 and it returns positive with video0 usually

     for i in range(10):
         vid = cv2.VideoCapture(i)
         if vid.isOpened():
             status_label.config(text="Camera Found\tPort: video" + str(i), fg="green")
             print("Camera Found port: " + str(i))
             break
    
  • GPU Memory is at 256

  • libcamera-hello runs and I see myself in the camera but I cannot get it to work in the software I coded

  • Legacy Camera is enabled in raspi-config

  • Details of cat /etc/os-release

     PRETTY_NAME="Raspbian GNU/Linux 11 (bullseye)"
     NAME="Raspbian GNU/Linux"
     VERSION_ID="11"
     VERSION="11 (bullseye)"
     VERSION_CODENAME=bullseye
     ID=raspbian
     ID_LIKE=debian
    

Really stumped at this. does Arducam have specific dependencies that I somehow missed. -I am just hoping that theres no need to buy the same module again to compare- Edit: Nope. Even with another module its still the same

Edit: I tried dmesg and saw these

    [ 1638.317199] unicam fe801000.csi: Failed to start media pipeline: -22
    [ 1678.153954] unicam fe801000.csi: Wrong width or height 640x480 (remote pad set to 1296x972)

I am still trying to figure out what this means

I get global cap_v4l.cpp: 1119 tryIoctl VIDEOI0(V4L2:/dev/video0): select() timeout now that i did a fresh install and everything.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.