-1

Raspberry Pi 4 and Latest Raspbian Bookworm OS.

I want to have Pi 4 communicate over serial connection using GPIO14 (BCM) and GPIO15 (BCM) or UART TX and UART RX.

I have followed the same setups that I have done for my previous Pis (2 and 3) as follows to enable serial communication.

  • executed sudo raspi-config to enable serial interface to YES.
  • installed wiringpi.
  • set GPIO14 and GPIO15 to ALT0.
  • Added enable_uart=1 and also disabled bluetooth dtoverylay=disable-bt in /boot/config.txt.
  • Disabled ttyAMA0 by sudo systemctl mask [email protected]
  • Reboot Pi.

These steps works and worked on my previous versions of pi but not on Pi 4.

No data is transmitted, but after much testing I noticed that whenever I re-enable bluetooth by commenting out dtoverlay=disable-bt in /boot/config.txt Pi 4 transmits outgoing data but DOES NOT READ the incoming serial data.

There is obviously some differences in Pi 4 and the previous versons of Pis. I can't seem to find any solutions that work so far.

Any hints or clues?

1
  • You have posted no diagnostics and are using unusual (and unnecessary) commands. If you just tried the standard commands it should work. Frankly I fail to understand WHY so many people want to disable Bluetooth. The Pi4 has 5 usable UART.
    – Milliways
    Nov 11, 2023 at 0:26

1 Answer 1

0

In the latest version of Rasperry Pi OS from late 2023, with the Bookworm kernel, config.txt should be in /boot/firmware, ie /boot/firmware/config.txt

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.