0

I have a Raspberry Pi, with the lite version of Raspberry Pi OS, OpenMediaVault, and Plex installed. The drive is below 70% health, so wanted to replace it with a new drive. I tried cloning it with CloneZilla, but booting the new disk on the RPI, says GPT: No bootable partitions.

I copied the disk sector by sector, so I would assume, it's a perfect copy.

EDIT: So this is what happened. First boot, it was just in an endless loop of not finding a bootable partition. Second, was when I was writing the first message here, but after a long endless loop of not finding a bootable partition, the system was suddenly booted up correctly. Third boot, there were a few messages on the screen, then a total blank screen for a long time, but the SSD is flashing constantly.

0

1 Answer 1

0

Fixed.

I found out, there was another software, GParted, that could work with partitions, almost like CloneZilla. It can't copy partitions from one disk, to another, but it has a build-in terminal, so that I could use dd. Not that I knew that dd could copy disks 1:1, I thought it was for files and folders only. But this guide helped me: https://www.youtube.com/watch?v=YmFuBiKtes0

I could see in GParted, that the MBR was not the same size, in the Clonezilla copied MBR, so not a perfect copy. But I verified with sudo gdisk /dev/sdb, that there was a functional MBR, the disk just wouldn't boot more than once, out of ten attempts.

So I ran sudo dd if=/dev/sdc of=/dev/sdb to make a new copy of all partitions (I verified which disk was which with sudo smartctl -i /dev/sdc & sudo smartctl -i /dev/sdb), then attached the new disk to the RPI 4, and it booted right up. And it has booted up all times, I've tried since.

So I didn't really use GParted, other than for Linux command line access via terminal, as my PC is Windows only. And the drives were the same size, so I had no need for the features of GParted. Btw., both CloneZilla and GParted was running from an .img image, on a USB, then booted up.

And yes, Raspberry Pi 4 can actually boot from a GPT boot record, but you have to reformat the disk, and do a lot of stuff, so not an option, and unneeded for my case.

2
  • You can use a Start menu - acessories - sd card copier uner RPI os. Always worked well for me, copying between SD cards, USB drives and Sata adapters. Nov 21, 2023 at 21:30
  • As i wrote in my first comment, it's the lite version I use, with no OS.
    – Akyhne
    Apr 19 at 16:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.