1

Both browsers Chromium and Firefox are not opening in Raspberry Pi. I installed the Raspbian OS from Raspberry Pi Imager and all is working fine but browsers are not opening. I checked with my old memory card browsers are opening but on the new memory card, they are not working. I have reinstalled chromium but it is still the same. It seemed to be some graphics problem but all others are working fine.

enter image description here

I tried through terminal and it is giving like this: enter image description here

4
  • I’m assuming you are using Pi OS Bookworm and connecting over VNC? There are issues with VNC discussed on the Pi forums. Turning of wayland in raspi-config might help. forums.raspberrypi.com
    – CoderMike
    Commented Nov 20, 2023 at 14:34
  • @CoderMike Can you be more specific? I don't know much about it and I am using it through SSH. Commented Nov 20, 2023 at 14:52
  • 1
    There's a new display server backend ("Wayland") used with the GUI stack on Bookworm. The old one is X11, aka. Xorg or just "X". You can switch back to the old one using raspi-config: raspberrypi.stackexchange.com/q/144866/5538 Please let us know if this works.
    – goldilocks
    Commented Nov 20, 2023 at 16:01
  • @goldilocks It's not working. Commented Nov 21, 2023 at 7:43

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.