0

I'm trying to update my RPi but keep giving me an error:

failed to fetch some archives maybe run apt-get update or try with ..fix.missing?

But the problem is when I run apt-get update still nothing changes.

What can I do to fix it?

  • 1
    If possible the exact apt-get commands you're running and the output from them could be useful for finding a solution. – Fred Mar 16 '14 at 8:14
  • We really can't help you unless we have the exact command you are running and the output from that (the entire thing, including all errors). If you would include those it would help us resolve your issue faster and better. – RPiAwesomeness Jun 15 '14 at 18:32
1

Try running sudo apt-get update.

Your OS could also be out of date and need an upgrade. Try sudo apt-get upgrade

1

Perhaps your problem is that you do not have an internet connection. Try running ping www.google.com and see if that works, or if you cannot do that.

  • never too late to check the basics :) – codedude Oct 14 '14 at 1:23
  • yeah lol i spent 2 weeks with this same issue, until I realized that I needed a static IP to get the internet working with a bridged connection. If this does happen to be the authors problem, suntimebox.com/raspberry-pi-tutorial-course/week-3/day-5 worked great for me – quixotrykd Oct 14 '14 at 2:28
0

You probably need to run apt-get update -f to fix this error.

and you could also make a habit of updating through the raspi-config utility, apparently it handles more updates than just the apt-get.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.