0

I am trying to install mediapipe on my Raspberry Pi 3B running Raspbian GNU/Linux 12 (bookworm) on ARMv7 Processor rev 4 (v7l).

I have created a virtual environment, venv and already installed opencv-contrib-python (4.8.1.78) and numpy(1.26.2).

  1. I tried pip install mediapipe and python -m pip install mediapipe both of them results in this error:
Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
ERROR: Could not find a version that satisfies the requirement mediapipe (from versions: none)
ERROR: No matching distribution found for mediapipe
  1. Another approach I tried was running pip install mediapipe-rpi3 as mentioned here. This installs the package successfully but upon doing import mediapipe it results in this error:
(venv) sanskar@raspberrypi:~ $ python
Python 3.11.2 (main, Mar 13 2023, 12:18:29) [GCC 12.2.0] on linux
Type "help", "copyright", "credits" or "license" for more information.
>>> import mediapipe
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/local/lib/python3.11/dist-packages/mediapipe/__init__.py", line 16, in <module>
    from mediapipe.python import *
  File "/usr/local/lib/python3.11/dist-packages/mediapipe/python/__init__.py", line 17, in <module>
    from mediapipe.python._framework_bindings import resource_util
ModuleNotFoundError: No module named 'mediapipe.python._framework_bindings'

I am unsure how to get around these errors and install mediapipe successfully. I am also open to try a new approach or any workaround to install mediapipe.


Additional Context:

I need to use Mediapipe's pose solution (mp.solutions.pose.Pose()) in a python script I am trying to run on my Raspberry Pi, and for that, I need to install Mediapipe. So, If there is some way that I can somehow get the necessary files/pkg only for Pose() solution and make this script work, then I can try them as well.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.