-1

I am completely new to microcontroller in general and I am following along the kitronik discovery booklet. I have the circuit below built on my breadboard. When I run this circuit on wokwi.com it lights the LED as expected though on my actual breadboard it does not - see codes and screenshots below.

Any help would be very appreciated

import machine

LED = machine.Pin("LED",machine.Pin.OUT)
BUTTON = machine.Pin(0,machine.Pin.IN,machine.Pin.PULL_DOWN)

while True:
    LED.value(BUTTON.value())

actual breadboard enter image description here

wokwi.com diagram enter image description here

2 Answers 2

2

It looks as thought your header pins are not soldered onto the Pico.

You will not get good contact unless you solder the header pins to the pico.

2
  • It is a contact issue, indeed. Wiggling it around, I can have it work (turn on and off). Thank you for the help
    – Teddy
    Dec 9, 2023 at 13:59
  • Incredible... really.
    – Seamus
    Dec 9, 2023 at 19:05
0

If the header is not really soldered with the pico board, please solder the header and place it on a breadboard like this:

https://images.theengineeringprojects.com/image/webp/2022/05/Interfacing-PIR-sensor-and-RPi-25.jpg.webp?ssl=1

If the problem is not gone, please test the continuities of your jumper wires too. You can also cross-check your code with this one:

https://www.hackster.io/Ramji_Patel/raspberry-pi-pico-and-button-321059

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.