0

I have a device all setup and it works on my AOC monitor, however when I connect the device to a TV or projector I see the first few seconds of terminal output as ubuntu boots up, then the screen cuts out and I get the No Device Connected error from my TV or Projector.

Any idea why this works fine on a monitor but not a television or projector?

I remember having a similar issue on my Pi 3 when I built it out as a retro pi and the fix then was to set the following options in /boot/config.txt:

hdmi_force_hotplug=1
hdmi_group=1
hdmi_mode=31

I tried adding those to /boot/firmware/config.txt and still no luck. I verified that my working pi 3 does in fact work on the same device I'm testing the zero on, so it should be possible, but I'm missing something.

Any help is appreciated.

Specs: Pi zero 2 Ubuntu Server 23.10

1
  • probably because a TV is not a monitor ... exploring the difference may lead to an answer
    – jsotola
    Dec 23, 2023 at 18:20

1 Answer 1

0

On a hunch I tried a different power adapter and that fixed the issue. I have no clue why, but I switched from a micro usb that had a wall plug hard wired to it (that didn't work), to a regular micro usb cable plugged into a brick (That worked!).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.