0

I tried to install openvpn client, I have a pi 5 with raspberry pi OS 64-bit

I ran the apt updates and then ran sudo apt install openvpn -y

and got an error:

Reading package lists... Done Building dependency tree... Done Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies: openvpn : Depends: libpkcs11-helper1 (>= 1.28) but it is not installable Recommends: easy-rsa but it is not installable E: Unable to correct problems, you have held broken packages.

I am assuming that these packages don't work for the 64-bit version of the OS, how do I get the packages and install them?

If its not that then what is it?

7
  • you have held broken packages what packages have you held?? I am assuming wrong Dec 30, 2023 at 5:16
  • alternatively, have you done an apt update first? Dec 30, 2023 at 5:33
  • Yeah, didn't help Dec 30, 2023 at 17:37
  • The openvpn install worked perfectly on my RPi 5. You might have a broken package system??? You could try this search to find some tools and advice on repairing it. Otherwise, I'd suggest a re-install (you have backups?).
    – Seamus
    Dec 30, 2023 at 23:16
  • @Seamus do you have a 64 bit os? Dec 30, 2023 at 23:20

1 Answer 1

0

It turns out apt was messed up on install. I installed from raspberri pi installer and selected 64-bit os. I tried reinstalling apt and that did not work. I eneded up reinstalling the whole OS and downloading from this site: https://www.raspberrypi.com/software/operating-systems/ and then using the custom OS option and selecting the .xz image.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.