I downloaded a new version of rasberry pi operating system on a brand new SD card.

Linux xxx 6.1.0-rpi7-rpi-2712 #1 SMP PREEMPT Debian 1:6.1.63-1+rpt1 (2023-11-24) aarch64 GNU/Linux

I am getting these errors when trying to install samba on it. So what gives, have the packages not been built for the rpi 5 yet? What can I do to resolve these errors:

 sudo apt-get install samba samba-common-bin   
 Reading package lists...
 Done Building dependency tree... Done Reading state information...
 Done Some packages could not be installed. This may mean that you have
 requested an impossible situation or if you are using the unstable
 distribution that some required packages have not yet been created or
 been moved out of Incoming. The following information may help to
 resolve the situation:
 The following packages have unmet dependencies:  python3-samba :
 Depends: python3-tdb but it is not installable
                  Depends: python3-talloc (>= 2.3.4~) but it is not installable
                  Recommends: python3-gpg but it is not installable  samba : Depends: python3-dnspython but it is not installable
          Depends: tdb-tools but it is not installable
          Recommends: attr but it is not installable
          Recommends: python3-markdown but it is not installable
          Recommends: samba-vfs-modules but it is not going to be installed
          Recommends: samba-ad-provision but it is not going to be installed E: Unable to correct problems, you have held broken  packages. 

  • Format code as CODE not blockquotes.
    – Milliways
    Jan 5 at 5:26
  • Use apt NOT apt-get which is not designed for interactive use.
    – Milliways
    Jan 5 at 5:27
  • 1
    might be obvious, but did you sudo apt update first? Jan 5 at 7:09

1 Answer 1


You appear to be having issues with apt. Try this instead:

sudo apt update

...   # informs you of packages that need to be upgraded 

sudo apt -y full-upgrade

...   # upgrades all packages identified by `apt update`

sudo apt install samba samba-common-bin smbclient cifs-utils

I hope this will cure the problems you're seeing. Please let us know if it does not.

  • There were 0 upgrades after the full-upgrade and I still get the same error. The thing that I don't get is this is OS a brand new install with the raspi install tool on an SD card Jan 6 at 22:46
  • 1
    OK - Just tried this on my RPi 5 (bookworm), and while it installs successfully on my machine, for reasons unclear to me there are a ton of Python dependencies that result in a huge (142 MB) download. IOW I'm not clear on why this is happening to you - and not to me. If there isn't something that you've not disclosed, I'd have to guess that it's either something to do with using apt-get - but that seems unlikely. I think you should re-install your distribution, and try again... sorry, but I just cannot think of anything else.
    – Seamus
    Jan 6 at 23:40
  • 1
    Oh - one other thing: I didn't recognize the rasberry pi operating system you said you'd installed. When you download the image, you should make certain that it is an image that is compatible with RPi 5.
    – Seamus
    Jan 6 at 23:51
  • Yeah I'm thinking a reinstall would be best, I don't have a lot of time invested in this pi so a reinstall would be easiest Jan 7 at 18:04
  • I reinstalled, all my problems went away Jan 8 at 19:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.