1

okay, I started configuring my access point and then I tried to connect to it. until now both access point and client don't have ip addresses. I give it manually an ip address 12.12.12.12/24 to my access point ( which interface I have wlan0 and after hostapd i have another one named mon.wlan0 ) and of course set the ip address of the client 12.12.12.13/24 ( he is connected via wpa_supplicant command )

Now the problem when I ping from the client it didn't pass still frozen ? Please help !!

  • Can you better explain your network topology? You have a regular access point to which you're connecting the Pi? You have one Pi running hostapd and another Pi that's connecting to it? Have you checked /var/log/messages or tried running wpa_supplicant with the -d parameter and without -B to see if it's reporting any errors? – Fred Mar 18 '14 at 11:47
  • ok ubuntu <---> Raspberry pi(hostapd) <----> router – user12448 Mar 18 '14 at 12:12
  • usually the install dhcp server with hostapd. but I want to give manually ip addresses – user12448 Mar 18 '14 at 12:13
  • OK. You have an Ubuntu laptop or something with Wi-Fi, trying to connect to hostapd running on the Pi. I'd try running wpa_supplicant with debugging enabled as I previously suggested. It may be worth checking on the Pi as well if any errors are being reported. – Fred Mar 18 '14 at 13:39
  • wpa_supplicant connect with no problems – user12448 Mar 18 '14 at 13:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.