0

I am trying to run HA on a Raspberry PI 3B via USB but I am having a lot of issues.

My Setup:

  • Raspberry PI 3B
  • SATA to USB adapter with external power
  • 500GB SATA SSD
  • 5V 3A Power supply (up to 20V in fast charging)
  • For loading the image on the SSD I tried both the official raspberry PI imager and Balena etcher, both with no result. (I am on Windows)
  • Home Assistant 11.4

Issue:

When the Raspberry PI gets powered on, the ACT light blinks once, then the activity light on the SSD blinks few times, then nothing, ever again. The ACT light stays off, and so does the SSD activity light.

Even after 20 minutes, I still cannot access homeassistant, so I thought there was an issue with booting, but here comes the weird part:

On my gateway dashboard I see a device called homeassistant after a couple minutes of it being on, and I can ping it. However, to add to the weirdness, if I run

nmap -sP -PE [ip_address]

It returns host is down

Also, the ethernet port of the RPI starts blinking right after it is on, and stays this way indefinitely.

I also tried reaching it from ip_address:8123, but nothing.

I also have no monitor output (this was also the case when I was using Raspberry PI OS, so I guess my monitor is incompatible)

I also would like to add that I did not change any coniguration to the raspberry PI, other than enabling usb booting via this command:

echo program_usb_boot_mode=1 | sudo tee -a /boot/config.txt

Which I know works because I can boot via USB the raspberry PI OS with no problems, and because I have verified via:

vcgencmd otp_dump | grep 17:

I am not sure what to do, as I cannot tell where the issue is... Does no ACT light mean anything if you are not using an SD card? If it is not booting, I assume the ethernet port lights should not be active? Is this an issue with my network configuration?

UPDATE: I managed to find a monitor to connect that works, and I get a red (UBOOT) screen on a quarter of the monitor that is extremely hard to read. (It tries to set the resolution to 1000 x 5000)

This is what I can decipher from it:

...
Device 0: Unkown device

Device 0: unkown device
Waiting for ethernet connection... done
BOOTP broadcast 1
BOOTP broadcast 2
BOOTP broadcast 3
*** something option is number
DHCP client something to address 192.168.1.135 (number in ms)
*** no boot? file name: 
Using smsc95xx_eth device?
From server 192.168.1.1: our IP address is 192.168.1.135
Filename 'numbers.something'
Loading TTTTTTTT
Retry count exceeded: starting again 
Retrying file
Waiting for ethernet connection
Using something_eth device?
File name pelinux.cly [pxelinux.cfg?]
Load [memory address I presume]
Loading TTTTTTTT
Retry count exceeded: starting again 
Retrying file
Waiting for ethernet connection
Using smsc95xx_eth device?
From server 192.168.1.1: our IP address is 192.168.1.135
Filename pxelinux.something

I cannot really read much

14
  • 1
    You need to plug in a monitor that works or gain access remotely (eg. via SSH), otherwise you are just wasting your time.
    – goldilocks
    Jan 12 at 15:50
  • Just to confirm. 1. You are using the RPi3 version of HA, and 2. Have you tried using an SD card for HA, just to rule out some weird HA setup that may not expect to boot from a USB drive; and 3. You've booted Raspberry Pi OS from the same drive you are trying to use for HA? Jan 12 at 20:20
  • @goldilocks how do I access via SSH? I thought it was not possible without the add-on, or is there some config file I can put in the USB drive that allows me to connect? I actually have also tried my TV, but still no result... Do you think it is booting? Jan 12 at 23:52
  • @JaromandaX Yes j am using the version for RPI3, I have tried using an SD card for it, and it worked! Also yes, I have used the exact same drive/PSU/adapted ro successfully run RPI OS Jan 12 at 23:53
  • so, the only thing that doesn't work is HA on USB Drive - most likely some part of the HA image expects it to be on /dev/mmcblk0 - it's not the first Raspberry Pi image to be poorly created Jan 13 at 1:39

1 Answer 1

0

Not a proper solution, but what I ended up doing, and recommend at this point if you too are having issues, is to use both SD and SSD.

Install HA on the SD card and boot from there, so you solve yourself quite some problems, as this is the intended way.

Then, to address the issue with short SD card lifespan and increase performance, connect the SSD as well, and, once everything is installed, run "move data disk". This way, HA will run the DB on the SSD while keeping the OS on the SD card.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.