0

I frequently use vcgencmd get_camera command on the raspberry pi, It gives the following error-

vc_gencmd_send returned -1
vchi_msg_dequeue -> -1(22)

And then raspberry pi hangs. I then executed the following command- sudo vcdbg log msg

I get the following log- This is the sequence of events that are captured by vcdbg tool after executing

vcgencmd get_camera
sudo vcdbg log msg

001468.611: brfs: File read: /mfs/sd/config.txt
001472.708: brfs: File read: 4595 bytes
001505.614: HDMI0:EDID error reading EDID block 0 attempt 0
001506.880: HDMI0:EDID error reading EDID block 0 attempt 1
001508.145: HDMI0:EDID error reading EDID block 0 attempt 2
001509.408: HDMI0:EDID error reading EDID block 0 attempt 3
001510.673: HDMI0:EDID error reading EDID block 0 attempt 4
001511.938: HDMI0:EDID error reading EDID block 0 attempt 5
001513.203: HDMI0:EDID error reading EDID block 0 attempt 6
001514.466: HDMI0:EDID error reading EDID block 0 attempt 7
001515.732: HDMI0:EDID error reading EDID block 0 attempt 8
001516.996: HDMI0:EDID error reading EDID block 0 attempt 9
001518.020: HDMI0:EDID giving up on reading EDID block 0
001519.800: brfs: File read: /mfs/sd/config.txt
001522.437: gpioman: gpioman_get_pin_num: pin LEDS_PWR_OK not defined
001715.681: gpioman: gpioman_get_pin_num: pin DISPLAY_DSI_PORT not defined
001717.033: gpioman: gpioman_get_pin_num: pin LEDS_PWR_OK not defined
001717.090: *** Restart logging
001717.116: brfs: File read: 4595 bytes
001718.320: hdmi: HDMI0:EDID error reading EDID block 0 attempt 0
001719.590: hdmi: HDMI0:EDID error reading EDID block 0 attempt 1
001720.858: hdmi: HDMI0:EDID error reading EDID block 0 attempt 2
001722.127: hdmi: HDMI0:EDID error reading EDID block 0 attempt 3
001723.394: hdmi: HDMI0:EDID error reading EDID block 0 attempt 4
001724.664: hdmi: HDMI0:EDID error reading EDID block 0 attempt 5
001725.932: hdmi: HDMI0:EDID error reading EDID block 0 attempt 6
001727.201: hdmi: HDMI0:EDID error reading EDID block 0 attempt 7
001728.468: hdmi: HDMI0:EDID error reading EDID block 0 attempt 8
001729.738: hdmi: HDMI0:EDID error reading EDID block 0 attempt 9
001730.764: hdmi: HDMI0:EDID giving up on reading EDID block 0
001731.095: hdmi: HDMI0:EDID error reading EDID block 0 attempt 0
001732.365: hdmi: HDMI0:EDID error reading EDID block 0 attempt 1
001733.634: hdmi: HDMI0:EDID error reading EDID block 0 attempt 2
001734.904: hdmi: HDMI0:EDID error reading EDID block 0 attempt 3
001736.171: hdmi: HDMI0:EDID error reading EDID block 0 attempt 4
001737.441: hdmi: HDMI0:EDID error reading EDID block 0 attempt 5
001738.709: hdmi: HDMI0:EDID error reading EDID block 0 attempt 6
001739.979: hdmi: HDMI0:EDID error reading EDID block 0 attempt 7
001741.246: hdmi: HDMI0:EDID error reading EDID block 0 attempt 8
001742.516: hdmi: HDMI0:EDID error reading EDID block 0 attempt 9
001743.542: hdmi: HDMI0:EDID giving up on reading EDID block 0
001743.835: hdmi: HDMI:hdmi_get_state is deprecated, use hdmi_get_display_state instead
001743.859: HDMI0: hdmi_pixel_encoding: 162000000
001744.125: vec: vec_middleware_power_on: vec_base: 0x7e806000 rev-id 0x00002708 @ vec: 0x7e806100 @ 0x00000420 enc: 0x7e806060 @ 0x00000220 cgmsae: 0x7e80605c @ 0x00000000
001745.027: kernel=
001752.734: dtb_file 'bcm2710-rpi-3-b.dtb'
001757.128: brfs: File read: /mfs/sd/bcm2710-rpi-3-b.dtb
001757.151: Loaded 'bcm2710-rpi-3-b.dtb' to 0x100 size 0x7d8e
001772.166: brfs: File read: 32142 bytes
001787.233: brfs: File read: /mfs/sd/overlays/overlay_map.dtb
001876.140: brfs: File read: 2347 bytes
001878.935: brfs: File read: /mfs/sd/config.txt
001879.490: dtparam: audio=on
001886.216: dtparam: spi=on
001894.311: dtparam: i2c_arm=on
001903.313: dtparam: i2c0=on
001919.360: dtparam: i2c1=on
001934.533: brfs: File read: 4595 bytes
001935.340: brfs: File read: /mfs/sd/cmdline.txt
001935.395: Read command line from file 'cmdline.txt':
001935.414: 'console=tty1 root=PARTUUID=57c9ce7f-02 rootfstype=ext4 fsck.repair=yes rootwait quiet splash plymouth.ignore-serial-consoles'
001951.242: gpioman: gpioman_get_pin_num: pin EMMC_ENABLE not defined
002568.058: brfs: File read: 125 bytes
002966.337: brfs: File read: /mfs/sd/kernel7.img
002966.353: Loaded 'kernel7.img' to 0x8000 size 0x67ebe0
002966.378: Device tree loaded to 0x2eff7c00 (size 0x830d)
002971.879: gpioman: gpioman_get_pin_num: pin SDCARD_CONTROL_POWER not defined
006749.383: vchiq_core: vchiq_init_state: slot_zero = 0xf4180000, is_master = 1
011537.171: camsubs: Looking for camera 0: i2c_port = 0, led gpio = 134, power enable gpio = 133
011832.827: camsubs: Camera not found
011832.923: camsubs: Looking for camera 0: i2c_port = 0, led gpio = 134, power enable gpio = 133
011834.531: camsubs: Camera found OK
2037961.329: mmal: mmal_port_event_send: event lost on port 1,0 (buffer header callback not defined)
2041814.021: mmal: mmal_vll_load: could not load VLL 'videnc.vll':
2044585.965: mmal: mmal_vll_load: could not load VLL 'videnc.vll':
2045758.621: mmalsrv: send_buffer_to_host: tx failed:size 292 st -1
2046434.487: mmal: mmal_vll_load: could not load VLL 'videnc.vll':
2046935.509: mmalsrv: send_buffer_to_host: tx failed:size 292 st -1
308846.657: mmal: mmal_port_event_send: event lost on port 1,0 (buffer header callback not defined)
311757.300: mmal: mmal_vll_load: could not load VLL 'videnc.vll':
314165.724: mmal: mmal_vll_load: could not load VLL 'videnc.vll':
315328.380: mmalsrv: send_buffer_to_host: tx failed:size 292 st -1
315921.146: mmal: mmal_vll_load: could not load VLL 'videnc.vll':
316305.855: mmalsrv: send_buffer_to_host: tx failed:size 292 st -1
604736.413: mmal: mmal_port_event_send: event lost on port 1,0 (buffer header callback not defined)
608865.168: mmal: mmal_vll_load: could not load VLL 'videnc.vll':
611691.812: mmal: mmal_vll_load: could not load VLL 'videnc.vll':
612854.009: mmalsrv: send_buffer_to_host: tx failed:size 292 st -1
613495.711: mmal: mmal_vll_load: could not load VLL 'videnc.vll':
613985.760: mmalsrv: send_buffer_to_host: tx failed:size 292 st -1
2581861.243: mmal: mmal_vll_load: could not load VLL 'videnc.vll':
2584944.266: mmalsrv: send_buffer_to_host: tx failed:size 292 st -1
2961077.573: mmal: mmal_vll_load: could not load VLL 'videnc.vll':
2964141.652: mmalsrv: send_buffer_to_host: tx failed:size 292 st -1
3030729.998: mmal: mmal_port_event_send: event lost on port 1,0 (buffer header callback not defined)
3032887.677: mmal: mmal_vll_load: could not load VLL 'videnc.vll':
3035355.466: mmal: mmal_vll_load: could not load VLL 'videnc.vll':
3036489.581: mmalsrv: send_buffer_to_host: tx failed:size 292 st -1
3037025.335: mmal: mmal_vll_load: could not load VLL 'videnc.vll':
3037392.853: mmalsrv: send_buffer_to_host: tx failed:size 292 st -1
3294449.260: mmal: mmal_vll_load: could not load VLL 'videnc.vll':
3294543.218: mmalsrv: send_buffer_to_host: tx failed:size 292 st -1
3550194.029: mmal: mmal_port_event_send: event lost on port 1,0 (buffer header callback not defined)
3552420.983: mmal: mmal_vll_load: could not load VLL 'videnc.vll':
3555750.171: mmal: mmal_vll_load: could not load VLL 'videnc.vll':
3556890.074: mmalsrv: send_buffer_to_host: tx failed:size 292 st -1
3557471.523: mmal: mmal_vll_load: could not load VLL 'videnc.vll':
3557835.313: mmalsrv: send_buffer_to_host: tx failed:size 292 st -1
3942123.149: mmal: mmal_vll_load: could not load VLL 'videnc.vll':
3942205.497: mmalsrv: send_buffer_to_host: tx failed:size 292 st -1
1157023.262: mmal: mmal_port_event_send: event lost on port 1,0 (buffer header callback not defined)
1161383.096: mmal: mmal_vll_load: could not load VLL 'videnc.vll':
1164277.121: mmal: mmal_vll_load: could not load VLL 'videnc.vll':
1165439.846: mmalsrv: send_buffer_to_host: tx failed:size 292 st -1
1166125.112: mmal: mmal_vll_load: could not load VLL 'videnc.vll':
1166584.570: mmalsrv: send_buffer_to_host: tx failed:size 292 st -1

Then, if I try to reboot the pi , and again try to access the pi through putty , it gives network connection error and throw network connection error...Then I have to reset power the pi to access it again .. after reaccessing the pi after powerreset , I am able to perform vcgencmd get_camera without any problem

3
  • 1
    What OS? What Pi?
    – Milliways
    Commented Jan 13 at 7:48
  • OS release-- PRETTY_NAME="Raspbian GNU/Linux 11 (bullseye)" NAME="Raspbian GNU/Linux" VERSION_ID="11" VERSION="11 (bullseye)" VERSION_CODENAME=bullseye ID=raspbian ID_LIKE=debian HOME_URL="raspbian.org" SUPPORT_URL="raspbian.org/RaspbianForums" BUG_REPORT_URL="raspbian.org/RaspbianBugs" PI Information- Model : Raspberry Pi 3 Model B Rev 1.2 Commented Jan 14 at 10:08
  • Do not put detail in comments EDIT your question (and preferably tag with OS)
    – Milliways
    Commented Jan 14 at 11:08

1 Answer 1

0

Bullseye does not support Picamera

Install libcamera

1
  • I have enabled legacy camera, then it should be supported..There is certain reason that I want to use legacy camera Commented Jan 15 at 18:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.