1

I need my raspberry (new Pi OS with debian bookworm) to show a certain web page in full mode, so I run this script

firefox -kiosk -private 'www.example.com'

and can expect firefox to open www.example.com in full screen according to documentation. This does not happen in my case. The window might be "full screen" but is not centered. I have a workaround for that at the moment, my script looks like this

firefox 'www.example.com'
sleep 15
xdotool key F11

Do you have ideas why the -kiosk flag does not work?

1
  • when in doubt - read the docs ... it's -private --kiosk URL you'll need - note the order (since --kiosk requires the URL value) and the number of - Commented Jan 15 at 23:36

1 Answer 1

1

I had a similar problem for chromium instead of firefox, the solution might also work:

firefox -private --start-maximized --start-fullscreen 'www.example.com'

I found the answer here: https://github.com/raspberrypi/bookworm-feedback/issues/31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.