0

I'm setting up a dashboard computer using a Raspberry Pi 5 installed with Raspberry Pi OS 64-bit (Debian 12 Bookworm).

So far I've gotten it up and running with starting Chromium in fullscreen, kiosk mode with my dashboard on it, which works great.

However, I simply can't figure out how to hide the cursor that shows up in the middle of the screen by default. Most commonly, unclutter is recommended but no matter where I put unclutter -idle 0, it doesn't seem to have any effect. Even running it directly from the command line on the Pi via a terminal opened after booting to the desktop, does nothing. It's the same behavior no matter if my autostart of Chromium is there or not.

I've also tried adding xserver-command = X -nocursor to /etc/lightdm/lightdm.conf as suggested here but that has no effect either.

The ideal scenario is to only have the cursor hidden on inactivity but I'd greatly appreciate any pointers in the right direction.

1 Answer 1

0

I followed the solution at https://forums.raspberrypi.com/viewtopic.php?t=358083 this morning, which worked for me...

it has to do something with wayland you have to switch to x11 go to the raspi- config sudo raspi-config

Navigate the menus: 6 Advanced Options / A6 Wayland / W1 X11, activate and reboot when suggested.

then unclutter should work

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.