0

If I lsusb I see my portable hard drives. If I fdisk -l I do not. More concerning, when I listen closely to the drives that are plugged in, I hear them cycling every few seconds. I have a 5 amp power supply and both drives are USB-3.1. I tried with just one drive and it's the same thing. The pi is fully up to date. What can I do here?

When I run fdisk -l it hangs after the SD card, where I'd expect to see sda and sdb

Both external hard disks behave the same when plugged in by themselves. A thumb drive works as expected. Is the USB3.1 ports really rated appropriately?

Tested both external HDD simultaneously on a Pi4 8GB and it works correctly. What the heck? Need guidance.

1

1 Answer 1

0

You shouldn't be using fdisk to "see" your portable hard drives. fdisk is a tool for manipulating disk partition tables. Use lsblk --fs.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.