1

I have been trawling the net for days trying to get my RPi up as a Wi-Fi access point but I keep hitting the same problem, the dongle sees nothing over the air and nothing sees the dongle.

lsusb sees the dongle as:

Bus 001 Device 004: ID 148f:5370 Ralink Technology, Corp. RT5370 Wireless Adapter

iw list sees the device as having the following (among other) interface modes:

  • managed
  • AP
  • AP/WLAN
  • monitor

The interface has its IP address hardcoded via the /etc/network/interfaces file as:

auto lo eth0 wlan0

iface lo inet loopback

iface eth0 inet static
        address 192.168.1.1
        netemask 255.255.255.0
        broadcast 192.168.1.255
        # IP of my ADSL router box
        gateway 192.168.1.254

allow-hotplug wlan0
iface wlan0 inet static
        address 172.29.1.1
        netmask 255.255.255.0

and indeed the device comes up and is configured when I start my Pi:

/etc/network# ifconfig wlan0
wlan0     Link encap:Ethernet  HWaddr 00:87:33:51:03:88
          inet addr:172.29.1.1  Bcast:172.29.1.255  Mask:255.255.255.0
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

All fine so far but things now start to fall apart. It cannot see any access points:

/etc/network# iw wlan0 scan
/etc/network#

and there are plenty around, one about two feet from the RPi itself!

In desperation I tried just configuring hostapd to see if other Wi-Fi devices could see the RPi but nothing was detected and for some reason hostapd removes the IP address that I configured on the interface, but that's a different problem.

Can anyone offer suggestions or assistance? This is really bugging me!

|/|artin

  • Interesting. I got the same problem, did you buy this dongle: ebay.ca/itm/… – M. Mimpen Mar 19 '14 at 20:08
  • No, I bought mine from a local independent computer supplier, they are usually reliable so I am happy with the quality of the dongle. I will, however, try the dongle on another machine to check it as that is the only thing I can tink of that I have not one. – user200995 Mar 21 '14 at 12:26
1

Prompted by M. Mimpen's response I started looking at the dongle. I didn't think it would be a hardware problem given that the devices had actually worked previously but it turns out that this was the issue. Although the RPi could see the dongle the dongle itself was not seeing any kind of Wi-Fi activity.

So I bought an EDUP NANO-USB wifi card from eBay, an RTL8188CUS-based dongle without an aerial (I'd have preferred one with an aerial to reach further but could not find any) and tried it with a copy of hostapd that is available on the Realtek website. It worked although the daemon spat out an error hostapdioctl[RTL_IOCTL_HOSTAPD]: Operation not supported on startup, so I downloaded and compiled the latest source for hostapd and lo and behold it works cleanly!

So the things I have learned from this are:

  1. Don't forget to test the hardware again EVEN IF IT HAS WORKED BEFORE,
  2. Don't be afraid to compile sources to make your own drivers,
  3. Remember to uninstall any software before you compile and install from its sources, otherwise you run the risk of losing your compiled programs during the next update,
  4. Write down somewhere which software you have compiled in case you have to wipe and rebuild your RPi (actually I would recommend this for all the software you install so you know what you had previously).

|\/|artin

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.