0

I recently upgraded my RaspberryPi's storage using a 64GB USB Thumb Drive. I use my Pi as a BittorrentSync "Server" to have my files always accessible. Currently, this is the only operation it does (and the most important one). I only operate it via SSH.

This worked several weeks without problems. But recently I got some problems. It turned out that my pi stops working in the following way: If I plug in my USB thumb drive or my Keyboard, SSH sessions freeze and I can not open new ones. Even after a hard reboot. The USB-Keyboard does not work anymore. The Keyboard did work when I got my Pi (maybe about a year ago?), but since then I always used SSH. Also I used my keyboard on Ubuntu, so it should work on Linux, specific Debian, too

But everything has worked for weeks or maybe two months using this USB drive. So what changed? The internet provider, the router, and the network cable. The first two are working properly. I changed the network cable back and it changed nothing. I guess that’s just coincidence. Also, due to an accident it was turned off hard by disconnecting the power cable. Since about that time, the problems began.

Now, I reformatted the thumb drive with ext4 and reinstalled raspbian on the SD-card. It works without the USB drive, but with it I still get the described problems. I don't even come to the point to mount it and to install Bittorrent Sync again due to the freeze. I say Freeze, because the Session only "breaks" when I switch the Pi off.

Are there any logs that may tell me my Problems with USB? I heard that the Network also runs over the USB bus, but why didn't this happen before? How can I fix it?

Please tell me if you need any additional information. Thank you.

Data summary:

  • RaspberryPi Modell B on Raspbian (up-to-date)
  • connected via LAN cable, headless
  • 64GB USB Thumb Drive (Verbatim)
  • 8GB SD-Card
  • 1
    This sounds like a power problem. The Pi can not supply the full 500mA of the USB spec. You need to measure voltages, and possibly use a powered hub. – Milliways Mar 20 '14 at 0:42
  • But it's just a USB thumb/flash drive. It should not consume too much power I think. Also it worked several weeks. This is the USB drive, btw: amazon.de/dp/B0079GI3D4 – verpfeilt Mar 22 '14 at 13:40
0

It became worse and the pi did not even boot anymore. So I replaced the power supply. Now it works again. It was a relatively cheap power supply, and my RPI was already running a year with it, so it eventually did not offer enough mA anymore.

I didn't think that the power supply could get that worse. Come to think of it, it must have lost more than 30% of it's full power (which was 1000mA) in about one year of usage.

I replaced it with a power supply offering 1200mA.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.