1

have installed Ubuntu Server on my Raspberry Pi Zero W and I'm trying to enable USB mode. I have edited the cmdline.txt and config.txt files as suggested, but upon booting, the USB mode is not working. Additionally, I have plugged the USB into the second port near the HDMI port, but still no luck.

Any suggestions on how to properly enable USB mode on the Raspberry Pi Zero W running Ubuntu Server would be greatly appreciated. Thank you!

My host machine is ubuntu

My config file

[all]
kernel=vmlinuz
cmdline=cmdline.txt
initramfs initrd.img followkernel

[pi4]
max_framebuffers=2
arm_boost=1

[all]
# Enable the audio output, I2C and SPI interfaces on the GPIO header. As these
# parameters related to the base device-tree they must appear *before* any
# other dtoverlay= specification
dtparam=audio=on
dtparam=i2c_arm=on
dtparam=spi=on

# Comment out the following line if the edges of the desktop appear outside
# the edges of your display
disable_overscan=1

# If you have issues with audio, you may try uncommenting the following line
# which forces the HDMI output into HDMI mode instead of DVI (which doesn't
# support audio output)
#hdmi_drive=2

# Enable the serial pins
enable_uart=1

# Autoload overlays for any recognized cameras or displays that are attached
# to the CSI/DSI ports. Please note this is for libcamera support, *not* for
# the legacy camera stack
camera_auto_detect=1
display_auto_detect=1


[cm4]
# Enable the USB2 outputs on the IO board (assuming your CM4 is plugged into
# such a board)
dtoverlay=dwc2

[all]

My cmdline.txt file

console=serial0,115200 multipath=off dwc_otg.lpm_enable=0 console=tty1 root=LABEL=writable rootfstype=ext4 rootwait fixrtc modules-load=dwc2,g_ether

3
  • How did you install Ubuntu? AFAIK there never was an ARM6 version.
    – Milliways
    Feb 12 at 9:08
  • using raspberrypi imager Feb 12 at 9:29
  • perhaps dtoverlay=dwc2 needs to be placed in a location in that file for the Zero rather than the CM4 Feb 12 at 23:58

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.