0

I have a 256gb card and a Pi 0 W. both were sitting on the shelf for the past year until I decided to try flashing Raspbian with Pi imager and boot the Pi. I made the ssh file, plugged it in and noticed that a shard broke off of the RAM chip (on the top of the cpu). Then nothing happens, green led flashes from time to time, but Pi doesn't appear on WiFi.

I then tried to reflash Raspbian, but I couldn't, because the card was corrupted. I could format it once, but now can't, even in a camera.

the whole 238gb shows as RAW partition.

I tried putting it in a phone and put some pictures on it with MiXplorer, other managers don't recognize the card. Surprisingly, the pictures seem to stay on the card.

Did the broken Pi cause that? Is there a way to repair the card? Is it even corrupted, or do I not know something?

Thanks in advance.

2
  • 1
    You plugged it in and your RAM physically broke apart? Sounds like something went seriously wrong with the power supply. The SD card propably died together with your RPi.
    – StarCat
    Commented Feb 17 at 19:19
  • @StarCat no, I only noticed it after I plugged the SD card in. It probably broke sometime on the shelf.
    – Kofa
    Commented Feb 17 at 19:28

1 Answer 1

0

If you use the SD Association formatter you may be able to use the card (I have had some success this way).

You will need to do a low level format (which will take some time on such a large card).
I can't imagine why you would want to use a 256GB card on a Pi Zero

1
  • Tried that aswell, didn't work.
    – Kofa
    Commented Feb 23 at 22:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.