0

I am trying to talk to a device over serial (ttyAMA0 or serial0) and it works, but sometimes I get the following TX from my rpi4, which crashes the device I talk to:

[22763.820857] sysrq: HELP : loglevel(0-9) reboot(b) crash(c) terminate-all-tasks(e) memory-full-oom-kill(f) kill-all-tasks(i) thaw-filesystems(j) sak(k) show-backtrace-all-active-cpus(l) show-memory-usage(m) nice-all-RT-tasks(n) poweroff(o) show-registers(p) show-all-timers(q) unraw(r) sync(s) show-task-states(t) unmount(u) show-blocked-tasks(w) dump-ftrace-buffer(z)

I have already disabled shell over serial with raspi-config. In the /boot/config.txt I added the following lines:

enable_uart=1
dtoverlay=uart0
dtoverlay=miniuart-bt
dtoverlay=disable-bt

Is there some way to disable that or do I have to use another UART? And what causes sysrq to appear on UART?

EDIT: I also don't have console=serial0, 115200 in /boot/cmdline.txt. I also tried stopping [email protected], but that also didn't help.

1
  • Ultimatively, it came down to this command: sudo systemctl mask [email protected]
    – tester
    Commented Feb 21 at 10:58

1 Answer 1

0

I think I fixed not only the serial console problem, but also the permissions on ttyAMA0 by disabling this service:

sudo systemctl mask [email protected]

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.