6

I have an external 2TB WD Elemens harddisk recently purchased plugged into the USB of my Raspberry Pi with Xbian 1.0 beta 2 installed. This disk has internal power management so it enters stand-by mode after approx 30 minutes of not being read or written. So, although the disk does stop (spin down) after a while when no one uses the Pi, it spins up again after 10-15 minutes without any external intervention.

Why could this happen, what could be accessing it? I did the following things trying to prevent daemons from read/writing it and figure out what's causing it:

  1. Added exit 0 before any command in /etc/init.d/hdparm, ntp, rsync, anacron, smartmontools, smartd
  2. Commented everything out in /etc/init/anacron.conf, cron.conf
  3. Commented all out in /etc/cron.*/0anacron files
  4. Commented all out in /etc/crontab
  5. Added exit 0 before all commands in /etc/apm/event.d/* and /etc/apm/other.d/ifplugd
  6. Tested on Openelec - here the non-needed spin-up down does not occur, the disk stays on stand-by undefinetely if the Pi is not used
  7. I unmounted the disk and this still happens, so perhaps some kind of diagnostic request is sent to it through USB, but by which program?
  8. Mounted the disk with noatime, no success.

Any idea would be appreciated.

  • I have a B+ with XBian beta3, I don't have this issue, have you considered to run an update to the latest version? – Jean Jan 5 '15 at 16:35
  • My first thought was that it might be the updatedb cron, but since you've gotten that taken care of I looked a bit more. There is a handy trick to cause the kernel to dump everytime something access the disk: serverfault.com/questions/44294/… – portforwardpodcast Mar 31 '15 at 0:20
  • Is the system log written to the disk in question? – Dmitry Grigoryev Sep 27 '16 at 12:58
  • You can use audit to log all the disk activities. Just keep in mind not to make audit write to that disk. – v7d8dpo4 Sep 28 '16 at 6:20
0

Basically, the WD power management and Xbian drive management don't work together, at least on beta2. Look at this post. Disable the disk's internal power management and let Xbian run the show.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.