0

I am trying to configure batman-adv. I am using two raspberry pi 3a+. I have Raspberry Pi Os bookworm (not lite version) installed on them. Each raspberry has a wifi adapter (rtl8812bu chip used this driver: https://github.com/morrownr/88x2bu-20210702) which they use to connect to my home wifi network for ssh configuration. I configure Batman using this guide https://github.com/binnes/WiFiMeshRaspberryPi/blob/master/part1/PIMESH.md. First raspberry (raspberrypi3 also configured as gateway (ROUTE.md in guide))

However, after all the configuration, the batctl n command gives an empty list of neighbors:

xrou@raspberrypi3:~ ~ $ sudo batctl n
[B.A.T.M.A.N. adv 2022.3, MainIF/MAC: wlan0/b8:27:eb:f4:74:f2 (bat0/f6:58:1e:21:76:54 BATMAN_IV)]
IF Neighbor last-seen

Second raspberry:

xrou@rpimesh:~ ~ $ sudo batctl n
[B.A.T.M.A.N. adv 2022.3, MainIF/MAC: wlan0/b8:27:eb:95:77:3a (bat0/a2:eb:4d:33:a5:04 BATMAN_IV)]
IF Neighbor last-seen

on both raspberry pi the batctl if command produces the following:

xrou@raspberrypi3:~ $ sudo batctl if
wlan0: active

xrou@rpimesh:~ $ sudo batctl if
wlan0: active

This is what the ifconfig and iwconfig commands produce on the first raspberry:

xrou@raspberrypi3:~ $ sudo iwconfig
lo        no wireless extensions.

wlan0     IEEE 802.11  ESSID:off/any
          Mode:Managed  Access Point: Not-Associated   Tx-Power=31 dBm
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:on

wlan1     IEEE 802.11AC  ESSID:"RT-5GPON-6155"  Nickname:"WIFI@RTL88X2BU"
          Mode:Managed  Frequency:5.22 GHz  Access Point: 44:13:D0:B7:61:56
          Bit Rate:867 Mb/s   Sensitivity:0/0
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:****-****-****-****-****-****-****-****   Security mode:open
          Power Management:off
          Link Quality=64/100  Signal level=47/100  Noise level=0/100
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

bat0      no wireless extensions.

xrou@raspberrypi3:~ $ sudo ifconfig
bat0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1468
        inet 192.168.199.1  netmask 255.255.255.0  broadcast 192.168.199.255
        inet6 fe80::f046:83ff:feae:a4c8  prefixlen 64  scopeid 0x20<link>
        ether f2:46:83:ae:a4:c8  txqueuelen 1000  (Ethernet)
        RX packets 39  bytes 1638 (1.5 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 1  bytes 90 (90.0 B)
        TX errors 0  dropped 53 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 99  bytes 8743 (8.5 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 99  bytes 8743 (8.5 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlan0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether b8:27:eb:f4:74:f2  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlan1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.0.10  netmask 255.255.255.0  broadcast 192.168.0.255
        inet6 fe80::63ec:6dc4:66e2:2a58  prefixlen 64  scopeid 0x20<link>
        ether 90:91:64:06:3e:19  txqueuelen 1000  (Ethernet)
        RX packets 483  bytes 120813 (117.9 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 151  bytes 26303 (25.6 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

And second raspberry

xrou@rpimesh:~ $ sudo ifconfig
bat0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1468
        inet6 fe80::f4d4:56ff:fecd:a80b  prefixlen 64  scopeid 0x20<link>
        ether f6:d4:56:cd:a8:0b  txqueuelen 1000  (Ethernet)
        RX packets 47  bytes 1974 (1.9 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 1  bytes 90 (90.0 B)
        TX errors 0  dropped 28 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 101  bytes 8827 (8.6 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 101  bytes 8827 (8.6 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlan0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether b8:27:eb:95:77:3a  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlan1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.0.7  netmask 255.255.255.0  broadcast 192.168.0.255
        inet6 fe80::9133:2fec:b268:894a  prefixlen 64  scopeid 0x20<link>
        ether 90:91:64:06:3d:e4  txqueuelen 1000  (Ethernet)
        RX packets 488  bytes 123198 (120.3 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 117  bytes 20234 (19.7 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

xrou@rpimesh:~ $ sudo iwconfig
lo        no wireless extensions.

wlan0     IEEE 802.11  ESSID:off/any
          Mode:Managed  Access Point: Not-Associated   Tx-Power=31 dBm
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:on

wlan1     IEEE 802.11AC  ESSID:"RT-5GPON-6155"  Nickname:"WIFI@RTL88X2BU"
          Mode:Managed  Frequency:5.22 GHz  Access Point: 44:13:D0:B7:61:56
          Bit Rate:867 Mb/s   Sensitivity:0/0
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:****-****-****-****-****-****-****-****   Security mode                                                                                                             :open
          Power Management:off
          Link Quality=73/100  Signal level=67/100  Noise level=0/100
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

bat0      no wireless extensions.

For some reason the wlan0 interface is not configured properly. This is what it should be (from guide)

wlan0 IEEE 802.11 ESSID: "call-code-mesh"  
        Mode:Ad-Hoc Frequency:2.462 GHz Cell: 3A:BC:74:3B:A1:D9
        Tx-Power=31 dBm
        Retry short limit:7 RTS thr:off Fragment thr:off
        Power Management:on

I can't figure out what the problem is, can you help me?

2
  • You are using an OS not recommended for the Pi3A+ which uses a different network manager and running an archived application which uses an even older networking system. It is hardly surprising it doesn't work.
    – Milliways
    Commented Feb 23 at 8:37
  • @Milliways Sure i can use raspberry pi 4, but is pi os important the device it runs on? How do i make a mesh network? i heard about yggdrasil, can it work on my raspberry 3?
    – Xrou
    Commented Feb 23 at 9:08

1 Answer 1

0

I had a similar problem setting up batman-adv on a Raspberry Pi 3b+. What finally worked for me was installing the Buster version of Raspbian. I believe the tutorial you are using is based on the old network manager used in that OS, which was changed on newer versions.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.