1

I'm trying to use my Pi as a NAS (among other things), so I mounted an external HDD and set up samba to use it. However, it turns out now that when I connect from my mac I can't rename or delete files and directories on it.

These are the permissions on it currently:

drwxr-xr-x 1 root root 131072 Mar 19 20:02 disk1

I tried to chmod both the disk itself and folders on it, but I get the message that the function is not implemented.

From what I gathered, chmod is not supported for exFat. I used exFat so that I could unplug the disk and use it on both my macbook and my windows pc safely.

Is there anything I can do to fix this? Currently my options seem to be:

  • Format the disk to another file system.
  • Learn to live with the fact that I can store things on the NAS from other devices, but need to login to my Pi to alter/delete them

Is there anything I'm missing here? In case I need another file system, which would be recommended?

  • 1
    Can you display your /etc/samba/smb.conf? Could the "samba share" be configured with read only = yes or could samba default to read only = yes if the read only option is missing? My configuration has read only = no for my Samba defined shares. I followed these directions except that I formatted by external hard drive as ext4. – HeatfanJohn Mar 20 '14 at 20:04
  • I have the same issue, did you found any solutions? I mounted the drive as pi:nas and used force user = pi and force group = nas but still the same. – DOCTYPE HTML Jan 3 at 2:30
2

The permissions displayed are not on the disk itself, as exFAT does not support ownership etc, but are inherited from the directory in which it is mounted.

The permissions displayed indicate that only the owner of the files (root) has write permission. You could fix this by creating a Samba group, and giving this write permission.

Rather than using Samba (which is a b... of a protocol) you may want to try installing netatalk on the Pi. This would let you access the Pi filesystem from Finder, like a native file. (Of course this won't enable control of file ownership etc, because of the exFAT limitations.)

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.